Lee's Feature Complete PDE

Share you PDE file with our community
User avatar
Posts: 5362
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Wed May 04, 2016 2:11 am
And for the record, I made this same mistake when I installed :)

Posts: 10
Joined: Tue May 03, 2016 5:32 am
PostPosted: Wed May 04, 2016 2:21 am
Ok I found them in the img. My fault, I hadn't actually clicked on the 'folder' which contains all the files needed. As the icon is what looks like a help doc for Arduino I hadn't clicked on it. Sorry for the confusion. Will try again later on.

On another note, I installed the 1.6.8 dev copy on windows and that's working ok so far.

Thanks for your help :)
User avatar
Posts: 5362
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Wed May 04, 2016 2:29 am
Cool. Like I said, been there done that. Easy mistake :) glad that helped.

Posts: 10
Joined: Tue May 03, 2016 5:32 am
PostPosted: Wed May 04, 2016 5:22 am
If I try to compile your project with the standard RA its too big but no other errors, however when choosing the RA+ I see lots of Ethernet errors.

This is on the 1.6.8 so my guess is the library is out of date.

Code: Select all
C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\Ethernet.cpp: In member function 'void EthernetClass::begin(uint8_t*, IPAddress, IPAddress, IPAddress, IPAddress)':

C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\Ethernet.cpp:64:39: error: no matching function for call to 'W5100Class::setIPAddress(IPAddress::<anonymous union>&)'

   W5100.setIPAddress(local_ip._address);

                                       ^

C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\Ethernet.cpp:64:39: note: candidate is:

In file included from C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\Ethernet.cpp:1:0:

C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\utility/w5100.h:392:6: note: void W5100Class::setIPAddress(uint8_t*)

 void W5100Class::setIPAddress(uint8_t *_addr) {

      ^

C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\utility/w5100.h:392:6: note:   no known conversion for argument 1 from 'IPAddress::<anonymous union>' to 'uint8_t* {aka unsigned char*}'

C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\Ethernet.cpp:65:38: error: no matching function for call to 'W5100Class::setGatewayIp(IPAddress::<anonymous union>&)'

   W5100.setGatewayIp(gateway._address);

                                      ^

C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\Ethernet.cpp:65:38: note: candidate is:

In file included from C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\Ethernet.cpp:1:0:

C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\utility/w5100.h:368:6: note: void W5100Class::setGatewayIp(uint8_t*)

 void W5100Class::setGatewayIp(uint8_t *_addr) {

      ^

C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\utility/w5100.h:368:6: note:   no known conversion for argument 1 from 'IPAddress::<anonymous union>' to 'uint8_t* {aka unsigned char*}'

C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\Ethernet.cpp:66:38: error: no matching function for call to 'W5100Class::setSubnetMask(IPAddress::<anonymous union>&)'

   W5100.setSubnetMask(subnet._address);

                                      ^

C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\Ethernet.cpp:66:38: note: candidate is:

In file included from C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\Ethernet.cpp:1:0:

C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\utility/w5100.h:376:6: note: void W5100Class::setSubnetMask(uint8_t*)

 void W5100Class::setSubnetMask(uint8_t *_addr) {

      ^

C:\Users\danstevens\Documents\Arduino\libraries\Ethernet\utility/w5100.h:376:6: note:   no known conversion for argument 1 from 'IPAddress::<anonymous union>' to 'uint8_t* {aka unsigned char*}'
User avatar
Posts: 5362
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Wed May 04, 2016 9:58 am
The libraries dont work with the 1.6.8, Roberto posted a beta version with the dev library.

Posts: 12306
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Wed May 04, 2016 10:04 am
You have to use the Arduino release in the dmg package.
It's compiled differently from the standard arduino ide so it allows to use the wizard and the other tools.
Roberto.
User avatar
Posts: 5362
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Wed May 04, 2016 10:13 am
Roberti what happened with the dev release of the new ide csn't find the post?

Posts: 12306
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Wed May 04, 2016 10:49 am
viewtopic.php?f=7&t=5993
Roberto.

Posts: 10
Joined: Tue May 03, 2016 5:32 am
PostPosted: Wed May 04, 2016 10:59 am
rimai wrote:You have to use the Arduino release in the dmg package.
It's compiled differently from the standard arduino ide so it allows to use the wizard and the other tools.


At the time i was using the 1.6.8 dev RA package on windows.
User avatar
Posts: 5362
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Thu Jun 09, 2016 10:52 pm
Was just checking out the coordinates my Sunrise/Sunset was linked to and then was just curious how accurate the calculations are. While not exact, they're pretty damn close. I'm satisfied

What my RA says
Sunrise: 10:10
Sunset: 23:33

What timeanddate says
Sunrise 6:02 AM
Sunset 7:27 PM
PreviousNext

Return to My PDE/INO file

Who is online

Users browsing this forum: No registered users and 1 guest

cron