Expansion Reboots

Share you PDE file with our community

Posts: 119
Joined: Sat Apr 23, 2011 6:53 pm
PostPosted: Mon Aug 08, 2016 12:44 pm
When I put the system into feeding mode or water change mode my expansion relay reboots.
I recent installed the RA + board, but have never had 2 expansions on this unit.

Any thoughts?

here is my code

#include <ReefAngel_Features.h>
#include <Globals.h>
#include <RA_Wifi.h>
#include <Wire.h>
#include <OneWire.h>
#include <Time.h>
#include <DS1307RTC.h>
#include <InternalEEPROM.h>
#include <RA_NokiaLCD.h>
#include <RA_ATO.h>
#include <RA_Joystick.h>
#include <LED.h>
#include <RA_TempSensor.h>
#include <Relay.h>
#include <RA_PWM.h>
#include <Timer.h>
#include <Memory.h>
#include <InternalEEPROM.h>
#include <RA_Colors.h>
#include <RA_CustomColors.h>
#include <Salinity.h>
#include <RF.h>
#include <IO.h>
#include <ORP.h>
#include <AI.h>
#include <PH.h>
#include <WaterLevel.h>
#include <Humidity.h>
#include <DCPump.h>
#include <PAR.h>
#include <ReefAngel.h>

////// Place global variable code below here

////// Place global variable code above here

void setup()
// This must be the first line
ReefAngel.Init(); //Initialize controller
ReefAngel.Use2014Screen(); // Let's use 2014 Screen
// Ports toggled in Feeding Mode
ReefAngel.FeedingModePorts = Port1Bit | Port2Bit | Port5Bit | Port7Bit;
// Ports toggled in Water Change Mode
ReefAngel.WaterChangePorts = Port1Bit | Port2Bit | Port4Bit | Port5Bit | Port6Bit | Port7Bit;
ReefAngel.WaterChangePortsE[0] = Port7Bit | Port8Bit;
// Ports toggled when Lights On / Off menu entry selected
ReefAngel.LightsOnPorts = 0;
ReefAngel.LightsOnPortsE[0] = 0;
// Ports turned off when Overheat temperature exceeded
ReefAngel.OverheatShutoffPorts = Port4Bit | Port6Bit;
ReefAngel.OverheatShutoffPortsE[0] = Port1Bit;
// Use T1 probe as temperature and overheat functions
ReefAngel.TempProbe = T1_PROBE;
ReefAngel.OverheatProbe = T1_PROBE;

// Ports that are always on
ReefAngel.Relay.On( Port1 );
ReefAngel.Relay.On( Port2 );
ReefAngel.Relay.On( Port5 );
ReefAngel.Relay.On( Port7 );
ReefAngel.Relay.On( Box1_Port1 );
ReefAngel.Relay.On( Box1_Port2 );
ReefAngel.Relay.On( Box1_Port5 );
ReefAngel.Relay.On( Box1_Port6 );

////// Place additional initialization code below here

////// Place additional initialization code above here

void loop()
ReefAngel.MoonLights( Box1_Port4 );
ReefAngel.StandardHeater( Port4 );
ReefAngel.StandardHeater( Port6 );
ReefAngel.DosingPumpRepeat1( Box1_Port7 );
ReefAngel.DosingPumpRepeat2( Box1_Port8 );
////// Place your custom code below here

////// Place your custom code above here

// This should always be the last line
ReefAngel.Portal( "XXXXXX" );

Posts: 119
Joined: Sat Apr 23, 2011 6:53 pm
PostPosted: Thu Aug 11, 2016 4:11 pm
On another note, when the system comes out of water change or feeding the expansion doesnt power cycle

Posts: 119
Joined: Sat Apr 23, 2011 6:53 pm
PostPosted: Sun Aug 28, 2016 7:24 pm
So something else that just showed up. If port 1 the return pump port is in the on state and not in auto. the expansion does not reboot.

Any ideas?

Posts: 12116
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sun Sep 18, 2016 7:53 pm
Can you try removing the custom labels to see if that is affecting anything?

Posts: 119
Joined: Sat Apr 23, 2011 6:53 pm
PostPosted: Sun Sep 18, 2016 8:00 pm
Ill give it a shot and see. I know I had an issue with a reboot loop with some of the labels

Posts: 2
Joined: Fri Jul 08, 2016 8:07 pm
PostPosted: Sun Sep 25, 2016 7:09 am
I set all of the labels to blank just "" same thing happens

Sent from my SM-G935V using Tapatalk

Posts: 12116
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sun Sep 25, 2016 8:33 am
Remove the reference from the code.
Even if it is commented, it is still enabled.
When you are in water change mode, go to a browser within the same network and go to http://ipaddress:2000/r99
Send me the XML data you get back.

Return to My PDE/INO file

Who is online

Users browsing this forum: Google [Bot] and 1 guest