Lee's Next Project

Share you PDE file with our community
User avatar
Posts: 5328
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Wed Jul 26, 2017 9:56 pm
Ok, so the solution for the WaterLevel was to adjust the gain. As the Cloud Hub does not use the libraries per se, the gain adjustment is right in the default code :) Made it very easy. Roberto also fixed an issue with the calibration. I haven't yet been able to try it, but I can see that it at least works again. Once I have room in my mixing bins, I'll have to empty one into the other and calibrate it by registering empty and then filling it back up. Literally rinse and repeat :)

So that's out of the way now and I have a somewhat measurement that changes for my waterlevels, we're definitely making progress. Trying to decipher some network code tonight to see what I can do for the alerts... very slow going.
User avatar
Posts: 5328
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Thu Jul 27, 2017 11:16 pm
So made some progress and some setbacks in getting the alerts to work. I have the alerts working, but it seems the PortalConnection is made in a non-blocking fashion and so if I just call it once, it happens while there is no active connection. So a connection is started and I've already sent the alert. Need to figure out how to properly add this to the queue or whatever so that it can stay non-blocking. In the meantime I'm trying to test it out with a blocking call to connect...
User avatar
Posts: 5328
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Thu Jul 27, 2017 11:46 pm
Ok test with connect versus noblockconnect is working... what are the cons? If it locks up the controller trying to connect I would imagine the watchdog would reset? Will the timeout (being called after the connect...) do anything, is there a default timeout, can I run the timeout function before the connect? At least I have alerts now :)
User avatar
Posts: 5328
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Fri Jul 28, 2017 6:52 am
My pegboard order was cancelled :( I re-ordered from another vendor on eBay this time and it should arrive sooner than the other one. I may need to wait for the end of the month before I swap out though. We'll see. I'm going on vacation and will be away from the tank for like 12 days. Don't need any surprises while I'm gone. This will be a major change. Decisions...

Posts: 106
Joined: Thu Jun 28, 2012 1:46 pm
PostPosted: Sun Jul 30, 2017 1:39 am
Are there any threads/links/pictures or anything else related to the product? I've been pretty happy with the Reef Angel has a whole but I dislike having to remove the wireless and plug in the cable to make changes. I know I can resolve that issue with another add on but I don't really want to have to do that either. I also prefer hardwire compared to WiFi. So these two things sort of got me looking at other products (sticker shock) that meet the traditional network jack requirement.

I was scanning the forums today just to see what is going on when I saw this. Peaked my interest.
User avatar
Posts: 2602
Joined: Fri Mar 18, 2011 6:20 pm
Location: Illinois
PostPosted: Sun Jul 30, 2017 12:37 pm
saf1 wrote:Are there any threads/links/pictures or anything else related to the product? I've been pretty happy with the Reef Angel has a whole but I dislike having to remove the wireless and plug in the cable to make changes. I know I can resolve that issue with another add on but I don't really want to have to do that either. I also prefer hardwire compared to WiFi. So these two things sort of got me looking at other products (sticker shock) that meet the traditional network jack requirement.

I was scanning the forums today just to see what is going on when I saw this. Peaked my interest.

The RA Star has not officially been released yet. It is very close from what I understand. These are the first pictures and major discussions about it. I'm sure Roberto will have full details posted once it is officially released.


Sent from my iPad using Tapatalk

Posts: 95
Joined: Thu May 10, 2012 5:46 am
Location: Sunny (and hot) South Florida
PostPosted: Sun Jul 30, 2017 4:28 pm
Any idea on pricing? I think I gotta start squirreling away some cash. Funds hidden from wifeing eyes. All in anticipation of RA Star's imminent release.

(Sorry, Wifey is listing to It on audio book.)
Image
User avatar
Posts: 5328
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Sun Jul 30, 2017 7:39 pm
I'm sure we'll know when Roberto announces it. He said next week I believe. Anyway, let's get this thread back on track. So far alerts this weekend were working great. Everything upgraded today to point to the new cloud server. My peg board is on track and supposed to arrive early on Wednesday... should I upgrade before I leave or after? What would you do? :)
User avatar
Posts: 2602
Joined: Fri Mar 18, 2011 6:20 pm
Location: Illinois
PostPosted: Sun Jul 30, 2017 9:13 pm
lnevo wrote:I'm sure we'll know when Roberto announces it. He said next week I believe. Anyway, let's get this thread back on track. So far alerts this weekend were working great. Everything upgraded today to point to the new cloud server. My peg board is on track and supposed to arrive early on Wednesday... should I upgrade before I leave or after? What would you do? :)

probably after.

never fails when i decide to do something or change something and it is supposed to be straightforward and simple, something goes wrong and it takes me a long time to figure it out. it could be because i overlooked or forgot something but regardless.
besides, doing after will give you a chance to rethink and double check all of your steps of the upgrade process.


Sent from my iPad using Tapatalk
User avatar
Posts: 5328
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Mon Jul 31, 2017 12:33 am
It's the same code as my current RA, nothing really changed, but it's a revamp of where my relay boxes and modules are. It will be tough to wait, but I need to put my patience hat on. It's kind of stopping me from doing a lot of things to the tank that I need to. Anyway, I think I'm going to use the Star right now to start debugging the WaterLevel ATO timeout issue. Currently since I don't have the WL module plugged in, it tries to kick in every time and since it's not attached I can play with it...
PreviousNext

Return to My PDE/INO file

Who is online

Users browsing this forum: No registered users and 2 guests