Can't connect to RA Plus head unit

New members questions

Posts: 8
Joined: Tue May 17, 2016 4:36 pm
PostPosted: Sat Oct 22, 2016 7:36 pm
Hi,

I have purchased a used RA plus unit and having trouble connecting to it. I am using a Mac and believe I have all the required software installed. I have had to purchase a usb-TTL cable as my used bundle didn't have one.... But I believe that to be connected correctly (my colours differ a little, but I have: empty empty green yellow white red blue black).

When I got to upload the RA_preloaded sketch, it compiles, restarts the reef angel and then gives this error:
Rebooting Reef Angel Controller
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

I have tried all four com port options available to me, any other suggestions?

Thanks in advance,
Sam

Posts: 12269
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sat Oct 22, 2016 8:56 pm
You seem to be doing it all correctly.
It is even rebooting RA, which is what is supposed to happen.
The only thing I can think of is if the cable you just got is malfunctioning or the head unit is the problem.
Do you happen to have the wifi attachment too?
We could test the cable with the attachment.
Roberto.

Posts: 8
Joined: Tue May 17, 2016 4:36 pm
PostPosted: Sat Oct 22, 2016 9:27 pm
I do yes. Should I look up instructions for that somewhere?

Posts: 12269
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sat Oct 22, 2016 9:52 pm
Yeah, use the wifi utility to try to configure it.
Post the log that you get.
Roberto.

Posts: 8
Joined: Tue May 17, 2016 4:36 pm
PostPosted: Sun Oct 23, 2016 2:49 pm
ok cool - finally found the wifi utility was already installed as a part of the main installer and not at the link in the wifi utility manual :)

Appears my USB TTL cable is not playing the game as I crash the program on COM3 and get this error on COM6:

Opening Serial Port...
Verifying speed at 9600 baud
Connected to serial port COM6
> $$$
> set u b 57600
> set s p 0
> save
> reboot
Verifying speed at 57600 baud
Removing connection to COM6
Connected to serial port COM6
> $$$
** ERROR - Please disconnect and then reconnect the Reef Angel Wifi Attachment from the USB-TTL cable and try again.

Removing connection to COM6

It is possible that my colours are different than the official cable (well, I know 2 of them are, but perhaps the others are too?) Can anyone confirm if the RA uses the standard FT232RL USB to TTL cable? Or can anyone confirm one that they have bought elsewhere (ebay cables are $3 as opposed to $30 plus post from RA store)

Thanks,
Sam

Posts: 8
Joined: Tue May 17, 2016 4:36 pm
PostPosted: Sun Oct 23, 2016 2:50 pm
Just ordered this one, has same colours so hopefully works!
http://www.ebay.com.au/itm/FTDI-FT232RL ... Swo0JWPH4b

Posts: 8
Joined: Tue May 17, 2016 4:36 pm
PostPosted: Tue Nov 01, 2016 9:13 pm
Anyone have any other cable suggestions?

Return to For New Members

Who is online

Users browsing this forum: No registered users and 3 guests

cron