Uapp and Cloud server with RA*

New members questions

Posts: 7
Joined: Wed Dec 20, 2017 3:53 am
PostPosted: Tue May 15, 2018 4:58 am
I've finally gotten around to wiring up an ethernet cable for my new RA*, and deploying my web wizard code to the controller gives "Cloud Connection: Connected", so that looks fine. I was a bit confused initially about the wizard offering the option for "Cloud Wifi", but see it ignores that option anyway and generates the same line of code regardless:
Code: Select all

Now I've tried the uapp url at in a browser. In settings I just gave a dummy name, and my username and password without any IP address nor port (left blank) (as an aside: I'm not sure how this gets matched to my controller's data on the server side as I can't see my username info in the generated code?). I didn't configure my router nor switch at all for eg static IP, but I can now remotely control relay ports and the uapp is very responsive with updating data.

I did see that uapp didn't pick up the label names from my generated code. So I used the uapp menu option "Download Labels from Portal", which then made all the labels blank on uapp. So I went to the portal at and manually entered the labels there (is this necessary?) Now when I download the labels it gives the correct parameter labels (for the portal labels I could enter), but uapp doesn't pick up any of the relay labels, they just come back as "null" in uapp - is that a bug for RA* as it treats the relay as an expansion? Also, is there a way of labeling some other parameters like salinity and water level which get reported in uapp (with null label) but don't appear in the portal's list of labels? It would be nice if uapp (and the portal) could pick up the wizard's generated RA_LABEL names.

I also found the uapp graphs didn't have any data and the portal dashboard wasn't working at all as it didn't show any data for a couple of days. But once I restarted the controller that seems to have come right and now I am starting to get graphs appearing, so a restart might be good to remember.

BTW as I run my controller micro usb together with two of my own expansion mini usb cables through a narrow gap in a wall I found I was getting frequent and very frustrating bus errors until I put ferrite cores on both ends of each cable (missing even one core would give a bus error, but all seems okay when all the usb cables have the cores on).
User avatar
Posts: 5423
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Tue May 15, 2018 5:39 am
The RA* does not have any main relay box as they are all connected via the USB bus so they are considered expansions. The wizard if you are using the web wizard already knows who you are so it's embedded in the header files on the server your forum username and password. Salinty and Water Level labels are definitely there in port settings. The uapp graphs do take some time to populate. Sounds like you've got things moving along!

Posts: 7
Joined: Wed Dec 20, 2017 3:53 am
PostPosted: Tue May 15, 2018 2:07 pm
Thanks for the info on the header files. Today I do finally see the expansion relay box in the portal, and now too the salinity and water level labels appear there. So now my labels are sorted. Maybe the restart has something to do with that and it just took time to refresh on the portal.

But the uapp graph only plots data for the 10 minutes after I restarted the controller yesterday, same too for the portal web chart. I'm sure the controller is still working and communicating as uapp is giving current parameters, but the portal only seems to have received info for those 10 minutes and doesn't display current parameters.

Does upp pull its graph data from the portal or does the controller hold the data? Any ideas why the portal only took data for 10 minutes?


Return to For New Members

Who is online

Users browsing this forum: No registered users and 5 guests