ATO not shutting off pump

Basic / Standard Reef Angel hardware

Posts: 243
Joined: Thu Sep 01, 2011 8:44 pm
PostPosted: Thu Apr 13, 2017 7:49 pm
My ATO is not the expansion, its the the one that came with the RA unit. The valve goes up and down and I do hear the click when the valve is at the prescribed water level. However, the pump isn't shutting off. and then the time out trips, the red light comes on the RA unit, the pump still is running. Here is my code: is something wrong in not shutting off the relay?
Thanks for any help

Code: Select all
 #include <ReefAngel_Features.h>
#include <Globals.h>
#include <RA_Wifi.h>
#include <Wire.h>
#include <OneWire.h>
#include <Time.h>
#include <DS1307RTC.h>
#include <InternalEEPROM.h>
#include <RA_NokiaLCD.h>
#include <RA_ATO.h>
#include <RA_Joystick.h>
#include <LED.h>
#include <RA_TempSensor.h>
#include <Relay.h>
#include <RA_PWM.h>
#include <Timer.h>
#include <Memory.h>
#include <InternalEEPROM.h>
#include <RA_Colors.h>
#include <RA_CustomColors.h>
#include <Salinity.h>
#include <RF.h>
#include <IO.h>
#include <ORP.h>
#include <AI.h>
#include <PH.h>
#include <WaterLevel.h>
#include <Humidity.h>
#include <DCPump.h>
#include <PAR.h>
#include <ReefAngel.h>

////// Place global variable code below here


////// Place global variable code above here


void setup()
{
    // This must be the first line
    ReefAngel.Init();  //Initialize controller
    ReefAngel.Use2014Screen();  // Let's use 2014 Screen
    ReefAngel.AddHumidityExpansion();  // Humidity Expanion Module
    // Ports toggled in Feeding Mode
    ReefAngel.FeedingModePorts = Port1Bit;
    // Ports toggled in Water Change Mode
    ReefAngel.WaterChangePorts = Port1Bit;
    // Ports toggled when Lights On / Off menu entry selected
    ReefAngel.LightsOnPorts = Port2Bit | Port3Bit | Port4Bit;
    // Ports turned off when Overheat temperature exceeded
    ReefAngel.OverheatShutoffPorts = Port2Bit | Port3Bit | Port4Bit | Port7Bit;
    // Use T1 probe as temperature and overheat functions
    ReefAngel.TempProbe = T1_PROBE;
    ReefAngel.OverheatProbe = T1_PROBE;

    // Feeeding and Water Change mode speed
    ReefAngel.DCPump.FeedingSpeed=0;
    ReefAngel.DCPump.WaterChangeSpeed=0;


    // Ports that are always on
    ReefAngel.Relay.On( Port1 );
    ReefAngel.Relay.On( Port6 );

    ////// Place additional initialization code below here
   

    ////// Place additional initialization code above here
}

void loop()
{
    ReefAngel.ActinicLights( Port2 );
    ReefAngel.DayLights( Port3 );
    ReefAngel.DayLights( Port4 );
    ReefAngel.SingleATOLow( Port5 );
    ReefAngel.StandardHeater( Port7 );
    ReefAngel.StandardFan( Port8 );
    ReefAngel.PWM.SetDaylight( MoonPhase() );
    ReefAngel.DCPump.UseMemory = true;
    ReefAngel.DCPump.DaylightChannel = None;
    ReefAngel.DCPump.ActinicChannel = Sync;
    ////// Place your custom code below here
   

    ////// Place your custom code above here

    // This should always be the last line
    ReefAngel.Portal( "psyrob" );
    ReefAngel.DDNS( "psyrob-controller1.myreefangel.com" ); // Your DDNS is psyrob-99.90.0.55.myreefangel.com
    ReefAngel.ShowInterface();
}

Image

Posts: 243
Joined: Thu Sep 01, 2011 8:44 pm
PostPosted: Sat Apr 22, 2017 2:42 pm
Well, it happened again, poured two gallons of kalkwasser into the tank before I caught it. Put the whole tank in shock, had to run to the local fish store, buy 25 gallons of water and do an emergency water change. Nothing dead so far, but this ATO will go in the trash.
Image

Posts: 12201
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sun Apr 23, 2017 12:33 pm
Are you getting bus locks?
Roberto.

Posts: 243
Joined: Thu Sep 01, 2011 8:44 pm
PostPosted: Sun Apr 23, 2017 6:17 pm
No, no bus locks. It's like there was a siphon going on, but the return hose was above the water level of the sump, it wasn't in the water. I am going to check the Tom's aqua lift pump I was using, maybe the diaphram was stuck open?
Image

Posts: 104
Joined: Wed Nov 18, 2015 9:16 pm
PostPosted: Wed May 17, 2017 6:33 am
is the pump and output above the ato container?

Return to Standard

Who is online

Users browsing this forum: No registered users and 2 guests

cron