heater not turning off

Basic / Standard Reef Angel hardware

Posts: 328
Joined: Fri May 17, 2013 1:35 pm
PostPosted: Sun Dec 10, 2017 10:45 am
now that I have reprogrammed my controller after dealing with my lights issue my heater doesn't shut off when it gets above the desired temp. ive tried setting it to all three temp probes and none of them turn the heater off. I set the code up with the internal memory. here is the code I have loaded.
Code: Select all
#include <ReefAngel_Features.h>
#include <Globals.h>
#include <RA_Wifi.h>
#include <Wire.h>
#include <OneWire.h>
#include <Time.h>
#include <DS1307RTC.h>
#include <InternalEEPROM.h>
#include <RA_NokiaLCD.h>
#include <RA_ATO.h>
#include <RA_Joystick.h>
#include <LED.h>
#include <RA_TempSensor.h>
#include <Relay.h>
#include <RA_PWM.h>
#include <Timer.h>
#include <Memory.h>
#include <InternalEEPROM.h>
#include <RA_Colors.h>
#include <RA_CustomColors.h>
#include <Salinity.h>
#include <RF.h>
#include <IO.h>
#include <ORP.h>
#include <AI.h>
#include <PH.h>
#include <WaterLevel.h>
#include <Humidity.h>
#include <DCPump.h>
#include <PAR.h>
#include <ReefAngel.h>

////// Place global variable code below here

////// Place global variable code above here

void setup()
    // This must be the first line
    ReefAngel.Init();  //Initialize controller
    ReefAngel.Use2014Screen();  // Let's use 2014 Screen
    ReefAngel.AddSalinityExpansion();  // Salinity Expansion Module
    // Ports toggled in Feeding Mode
    ReefAngel.FeedingModePorts = 0;
    ReefAngel.FeedingModePortsE[0] = 0;
    // Ports toggled in Water Change Mode
    ReefAngel.WaterChangePorts = Port3Bit;
    ReefAngel.WaterChangePortsE[0] = 0;
    // Ports toggled when Lights On / Off menu entry selected
    ReefAngel.LightsOnPorts = 0;
    ReefAngel.LightsOnPortsE[0] = 0;
    // Ports turned off when Overheat temperature exceeded
    ReefAngel.OverheatShutoffPorts = Port7Bit;
    ReefAngel.OverheatShutoffPortsE[0] = 0;
    // Use T1 probe as temperature and overheat functions
    ReefAngel.TempProbe = T3_PROBE;
    ReefAngel.OverheatProbe = T3_PROBE;

    // Ports that are always on
    ReefAngel.Relay.On( Port4 );
    ReefAngel.Relay.On( Port6 );
    ReefAngel.Relay.On( Box1_Port3 );
    ReefAngel.Relay.On( Box1_Port4 );
    ReefAngel.Relay.On( Box1_Port7 );
    ReefAngel.Relay.On( Box1_Port8 );

    ////// Place additional initialization code below here

    ////// Place additional initialization code above here

void loop()
    ReefAngel.StandardATO( Port3 );
    ReefAngel.StandardHeater( Port7 );
    ReefAngel.MoonLights( Box1_Port6 );
    ////// Place your custom code below here

    ////// Place your custom code above here

    // This should always be the last line
    ReefAngel.Portal( "jjdezek" );


Posts: 12142
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sun Dec 10, 2017 11:15 am
Hard to tell with internal memory code.
What values do you have?
Did you try hard coding it?

Posts: 328
Joined: Fri May 17, 2013 1:35 pm
PostPosted: Mon Dec 11, 2017 2:59 pm
I have it the same as I had in the past. Turn on at 77.0 and turn off at 77.1. Since I redid the code it hasn’t been working right. Like right now my tank is at 77.3 and the heater is on.

Return to Standard

Who is online

Users browsing this forum: No registered users and 4 guests