Remote Uploading - RA*

Basic / Standard Reef Angel hardware

Posts: 16
Joined: Fri Jan 12, 2018 6:33 am
PostPosted: Thu Jan 18, 2018 12:42 pm
Hi there

Just hardwired my RA* on my LAN. I can use UAPP just fine with the cloud server. So I think communication is not a problem.

The first code I uploaded using the USB cable connected to my laptop. Worked just fine.

Using the webwizard I compiled the following code:

Code: Select all
#include <Salinity.h>
#include <ReefAngel_Features.h>
#include <Globals.h>
#include <RA_TS.h>
#include <RA_TouchLCD.h>
#include <RA_TFT.h>
#include <RA_TS.h>
#include <Font.h>
#include <RA_Wifi.h>
#include <RA_Wiznet5100.h>
#include <SD.h>
#include <SPI.h>
#include <Ethernet.h>
#include <EthernetDHCP.h>
#include <PubSubClient.h>
#include <Wire.h>
#include <OneWire.h>
#include <Time.h>
#include <DS1307RTC.h>
#include <InternalEEPROM.h>
#include <RA_ATO.h>
#include <LED.h>
#include <RA_TempSensor.h>
#include <Relay.h>
#include <RA_PWM.h>
#include <Timer.h>
#include <Memory.h>
#include <InternalEEPROM.h>
#include <RA_Colors.h>
#include <RA_CustomColors.h>
#include <RA_CustomLabels.h>
#include <RF.h>
#include <IO.h>
#include <ORP.h>
#include <AI.h>
#include <PH.h>
#include <WaterLevel.h>
#include <Humidity.h>
#include <PAR.h>
#include <DCPump.h>
#include <ReefAngel.h>
#include <SoftwareSerial.h>

////// Place global variable code below here

////// Place global variable code above here

void setup()
    // This must be the first line
    ReefAngel.Init();  //Initialize controller
    ReefAngel.SetTemperatureUnit( Celsius );  // set to Celsius Temperature
    // Ports toggled in Feeding Mode
    ReefAngel.FeedingModePorts = 0;
    ReefAngel.FeedingModePortsE[0] = 0;
    ReefAngel.FeedingModePortsE[1] = 0;
    // Ports toggled in Water Change Mode
    ReefAngel.WaterChangePorts = 0;
    ReefAngel.WaterChangePortsE[0] = 0;
    ReefAngel.WaterChangePortsE[1] = 0;
    // Ports turned off when Overheat temperature exceeded
    ReefAngel.OverheatShutoffPorts = 0;
    ReefAngel.OverheatShutoffPortsE[0] = 0;
    ReefAngel.OverheatShutoffPortsE[1] = 0;
    // Ports toggled when Lights On / Off menu entry selected
    ReefAngel.LightsOnPorts = 0;
    ReefAngel.LightsOnPortsE[0] = 0;
    ReefAngel.LightsOnPortsE[1] = 0;
    // Use T1 probe as temperature and overheat functions
    ReefAngel.TempProbe = T1_PROBE;
    ReefAngel.OverheatProbe = T1_PROBE;
    // Set the Overheat temperature setting
    InternalMemory.OverheatTemp_write( 300 );
    ////// Place additional initialization code below here

    ////// Place additional initialization code above here

void loop()


    ////// Place your custom code below here

    ////// Place your custom code above here

    // This should always be the last line
    ReefAngel.CustomVar[0] == 10;

// RA_STRING2=null
// RA_STRING3=null

So far so good.. choose the "Remote upload" option and hit "Upload". Got the following message:

Code: Select all
Progress: 100.00%
Your code was compiled sucessfully.

Remote upload firmware is ready.
Your Reef Angel Star should download and start the new firmware next time it connects to the server.
This process may take up to 5 minutes.teste.ino file saved to \sketch\libertyaquarium\

But the firmware never updated. Just waiting for it (one day so far)...

Posts: 12510
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Thu Jan 18, 2018 12:46 pm
Remote upload has been disabled for now.
There was a potential flaw that could cause the controller to become unresponsive if it downloaded the wrong file.
So, this needs to be revisited to make it more bullet proof.

Posts: 16
Joined: Fri Jan 12, 2018 6:33 am
PostPosted: Thu Jan 18, 2018 1:31 pm
Hummm ok. Hope it will come back soon

Posts: 66
Joined: Fri May 05, 2017 11:27 am
PostPosted: Wed Feb 14, 2018 3:58 pm
Any update on this? This was one of the biggest selling points for me to upgrade to the Star, and it appears to be dead in the water.

Posts: 12510
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Wed Feb 14, 2018 7:03 pm
I am working on that

Posts: 12510
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Wed Feb 14, 2018 8:50 pm
Ok, I just pushed the update.
You will need to upload the code at least once with the cable to enable the remote upload feature again.
Let me know if it works for you now.

Posts: 19
Joined: Thu Jan 04, 2018 10:47 pm
PostPosted: Thu Feb 15, 2018 12:34 pm
I just tried, and it seems to work fine. I made a couple of minor program changes so I would know I was running the new code. After uploading REMOTELY, I tested those changes, and they work so I'm running the code I uploaded remotely. Also, the controller is running everything like it should... so far so good. Thanks Roberto!

Return to Standard

Who is online

Users browsing this forum: No registered users and 3 guests