RA* shows disconnected

Basic / Standard Reef Angel hardware

Posts: 95
Joined: Wed Sep 02, 2015 4:39 pm
PostPosted: Sat Feb 24, 2018 12:11 am
has ip address but isn't connecting to cloud. is there something in code that I have to enter username and password for it to connect ? uapp is connectiong but not updating. searches isn't turning up anything after a couple hrs
Image

Posts: 95
Joined: Wed Sep 02, 2015 4:39 pm
PostPosted: Sat Feb 24, 2018 12:12 am
I see its connecting to the portal
Image

Posts: 12288
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sat Feb 24, 2018 9:15 am
Yes. When you generate your code using the web wizard, you have to enter the password and it is case sensitive.
Roberto.

Posts: 95
Joined: Wed Sep 02, 2015 4:39 pm
PostPosted: Sat Feb 24, 2018 9:30 am
Yeah I did that. I logged in with my old people first. Then realized I needed to change it. I then redid code with new PW add still isn't connecting to cloud. Web based uapp had no problems though
Image

Posts: 12288
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sat Feb 24, 2018 11:03 am
I'm pretty sure it is the password then.
Did you click encrypt and went all the way to generate and uploaded the code that was generated?
Roberto.

Posts: 95
Joined: Wed Sep 02, 2015 4:39 pm
PostPosted: Sat Feb 24, 2018 11:16 am
Yes a couple times.. Add changed my PW a couple times also
Image

Posts: 12288
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sat Feb 24, 2018 12:15 pm
Can you post the code you are uploading?
It shows a blank password.
Roberto.

Posts: 95
Joined: Wed Sep 02, 2015 4:39 pm
PostPosted: Sat Feb 24, 2018 2:07 pm
#include <Salinity.h>
#include <ReefAngel_Features.h>
#include <Globals.h>
#include <RA_TS.h>
#include <RA_TouchLCD.h>
#include <RA_TFT.h>
#include <RA_TS.h>
#include <Font.h>
#include <RA_Wifi.h>
#include <RA_Wiznet5100.h>
#include <SD.h>
#include <SPI.h>
#include <Ethernet.h>
#include <EthernetDHCP.h>
#include <PubSubClient.h>
#include <Wire.h>
#include <OneWire.h>
#include <Time.h>
#include <DS1307RTC.h>
#include <InternalEEPROM.h>
#include <RA_ATO.h>
#include <LED.h>
#include <RA_TempSensor.h>
#include <Relay.h>
#include <RA_PWM.h>
#include <Timer.h>
#include <Memory.h>
#include <InternalEEPROM.h>
#include <RA_Colors.h>
#include <RA_CustomColors.h>
#include <RA_CustomLabels.h>
#include <RF.h>
#include <IO.h>
#include <ORP.h>
#include <AI.h>
#include <PH.h>
#include <WaterLevel.h>
#include <Humidity.h>
#include <PAR.h>
#include <DCPump.h>
#include <ReefAngel.h>
#include <SoftwareSerial.h>

////// Place global variable code below here


////// Place global variable code above here


void setup()
{
// This must be the first line
ReefAngel.Init(); //Initialize controller
ReefAngel.Star();
// Ports toggled in Feeding Mode
ReefAngel.FeedingModePorts = 0;
ReefAngel.FeedingModePortsE[0] = Port1Bit | Port3Bit;
ReefAngel.FeedingModePortsE[1] = 0;
// Ports toggled in Water Change Mode
ReefAngel.WaterChangePorts = 0;
ReefAngel.WaterChangePortsE[0] = Port1Bit | Port3Bit;
ReefAngel.WaterChangePortsE[1] = 0;
// Ports turned off when Overheat temperature exceeded
ReefAngel.OverheatShutoffPorts = 0;
ReefAngel.OverheatShutoffPortsE[0] = Port2Bit;
ReefAngel.OverheatShutoffPortsE[1] = 0;
// Ports toggled when Lights On / Off menu entry selected
ReefAngel.LightsOnPorts = 0;
ReefAngel.LightsOnPortsE[0] = 0;
ReefAngel.LightsOnPortsE[1] = 0;
// Use T1 probe as temperature and overheat functions
ReefAngel.TempProbe = T1_PROBE;
ReefAngel.OverheatProbe = T1_PROBE;
// Set the Overheat temperature setting
InternalMemory.OverheatTemp_write( 805 );

// Ports that are always on
ReefAngel.Relay.On( Box1_Port1 );
ReefAngel.Relay.On( Box1_Port5 );
ReefAngel.Relay.On( Box1_Port6 );
ReefAngel.Relay.On( Box1_Port7 );
ReefAngel.Relay.On( Box1_Port8 );

////// Place additional initialization code below here


////// Place additional initialization code above here
}

void loop()
{
ReefAngel.StandardHeater( T1_PROBE,Box1_Port2,760,770 );
ReefAngel.SingleATO( true,Box1_Port3,180,0 );
ReefAngel.StandardLights( Box1_Port4,10,0,22,0 );
ReefAngel.PWM.SetDaylight( PWMSlope( 9,0,17,0,15,70,60,0 ) );
ReefAngel.PWM.SetActinic( PWMSlope( 9,0,17,0,15,70,60,0 ) );
ReefAngel.PWM.SetDaylight2( PWMSlope( 9,0,17,0,15,70,60,0 ) );
ReefAngel.PWM.SetActinic2( PWMSlope( 9,0,17,0,15,70,60,0 ) );

boolean buzzer=false;
if ( buzzer ) ReefAngel.BuzzerOn(2); else ReefAngel.BuzzerOff();

////// Place your custom code below here


////// Place your custom code above here

ReefAngel.Network.Cloud();
// This should always be the last line
ReefAngel.ShowTouchInterface();
}



// RA_STRING1=U2FsdGVkX19l4rVch5Wsz3j92ZZ1yaCjltVKjB3fddY=
// RA_STRING2=null
// RA_STRING3=null
// RA_LABEL LABEL_PORT11=Return
// RA_LABEL LABEL_PORT12=Heater
// RA_LABEL LABEL_PORT13=ATO
// RA_LABEL LABEL_PORT14=ReefBrite
// RA_LABEL LABEL_PORT15=Skimmer
Image

Posts: 12288
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sat Feb 24, 2018 3:30 pm
That yields a blank password.
Make sure you type the password and hit encrypt and go all the way to the end of the wizard and click generate.
Roberto.

Posts: 95
Joined: Wed Sep 02, 2015 4:39 pm
PostPosted: Sat Feb 24, 2018 3:34 pm
That's what I thought when I looked at it. That's why I asked about the code. So even though I don't have any attachments or expansions I can't click over them on the left? I have been clicking encrypt after every pw
Image
Next

Return to Standard

Who is online

Users browsing this forum: No registered users and 4 guests

cron