Page 1 of 3

Web portal and banner update issue

PostPosted: Mon Dec 29, 2014 5:48 pm
by sesame
a really strange things happened with my portal and banner.
last month, portal always shown latest updated in 25 Nov. Initially, i thought its a wifi device issue. Update firmware, check code and router, but doesn't work.
fortunately, as stare at portal site 5 min, it suddenly update to current status. :D :D :D :D

now problem is
1. portal always shown updated in 25 Nov as website initial login or refresh. but will updated to current status itself without refresh.
2. web banner always 25 Nov.
3. remote iphone app and web server working good.

is there something i can do to fix this issue?

initial login shown below:
Reef Angel wifi address: xxxxx.xxxxxxx.org:2000
My reefangelid: sesame
Connection Status: Ready
Last Update:2014/11/25 8:18:46
Displaying data from: Reef Angel Controller (live)

initial After 5 min:
Reef Angel wifi address: xxxxx.xxxxxxx.org:2000
My reefangelid: sesame
Connection Status: Ready
Last Update: 2014/12/30 8:41:37
Displaying data from: Reef Angel Controller (live)

Re: Web portal and banner update issue

PostPosted: Mon Dec 29, 2014 5:50 pm
by rimai
Check if your portal key is disabled. If enabled, make sure your code includes it.

Re: Web portal and banner update issue

PostPosted: Mon Dec 29, 2014 6:59 pm
by sesame
no password required in code or website setting.

Re: Web portal and banner update issue

PostPosted: Mon Dec 29, 2014 7:04 pm
by rimai
Do you have this in your code?
Code: Select all
ReefAngel.Portal("sesame");

Re: Web portal and banner update issue

PostPosted: Mon Dec 29, 2014 7:05 pm
by sesame
definitely

Re: Web portal and banner update issue

PostPosted: Mon Dec 29, 2014 7:15 pm
by rimai
To confirm, let's try this.
Connect the programming cable to RA.
Open Arduino and go to menu Tools->Serial Monitor
Make sure you have 57600 baud selected on the bottom right corner.
Leave it there for 15 to 20 minutes.
Post whatever you see in the window.

Re: Web portal and banner update issue

PostPosted: Mon Dec 29, 2014 9:41 pm
by sesame
thank you
let me have a try

Re: Web portal and banner update issue

PostPosted: Mon Dec 29, 2014 9:44 pm
by sesame
connected with Tera term and checked. seems wifi model already in 57600.
nothing happened.

Re: Web portal and banner update issue

PostPosted: Mon Dec 29, 2014 9:59 pm
by rimai
Not the wifi.
You need to connect to RA.
I want to make sure RA is sending data to the module correctly every 5 minutes.

Re: Web portal and banner update issue

PostPosted: Mon Dec 29, 2014 11:04 pm
by sesame
ok got it