Relay Activity on Portal

Related to the Portal

Posts: 471
Joined: Sat Jan 14, 2012 2:08 pm
Location: Montgomery Village, MD
PostPosted: Tue Jun 19, 2012 4:00 am
I did, but for some reason it has been acting very strange lately. Display looks weird, touch any commands get an exception error, etc. Not able to stop and start services, etc.

Went as far to uninstall and reinstall last night but no better. Is there something in this new code that client doesn't like?
Roscoe's Reefs - Starting Over Again:

Building new 29g Nano after landlord went berserk over my 4 75 gallon tanks, Multiple RA's, Water mixing stations, etc. Your help welcomed in remembering all I've forgotten.

Posts: 12493
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Tue Jun 19, 2012 7:36 am
Just make sure that you set the Client not to send parameter to reefangel.com
Or you will get issues in the Portal, similar to what you were mentioning.
Only one thing should send data. Either the controller or the Client.
Roberto.

Posts: 471
Joined: Sat Jan 14, 2012 2:08 pm
Location: Montgomery Village, MD
PostPosted: Mon Jun 25, 2012 7:10 pm
got this all fixed...

How would I write an alert on the portal that sent an email (or sms) if port 8 (main pump) turned off. I would also like it to sound the buzzer currently looked to atohigh. thx
Roscoe's Reefs - Starting Over Again:

Building new 29g Nano after landlord went berserk over my 4 75 gallon tanks, Multiple RA's, Water mixing stations, etc. Your help welcomed in remembering all I've forgotten.

Posts: 12493
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Mon Jun 25, 2012 7:14 pm
Currently, there is no way to do that, but I'll add to the list shortly.
Roberto.

Posts: 12493
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Thu Jun 28, 2012 10:32 am
Ok, so thinking about this one, what is that would cause Port 8 to turn off?
Roberto.

Posts: 471
Joined: Sat Jan 14, 2012 2:08 pm
Location: Montgomery Village, MD
PostPosted: Thu Jun 28, 2012 3:10 pm
my float valve on the i/o connector that detected an overflow situation on the main tank. (that now works thanks to you!)

My overflow kit from Glass holes will sometimes get clogged and when it does it overfills the tank and it starts pouring out. I mounted a float valve close to it and now when it happens it will trigger the float valve and shut off the pump.

This will work if I can hear the buzzer. If not at home then the portal could warn me that port 8 just turned off, then I would have time to get home, look into it, etc.

thx
Roscoe's Reefs - Starting Over Again:

Building new 29g Nano after landlord went berserk over my 4 75 gallon tanks, Multiple RA's, Water mixing stations, etc. Your help welcomed in remembering all I've forgotten.

Posts: 12493
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Thu Jun 28, 2012 5:47 pm
Oh, in this case it is simple.
You can use one of the custom variables.
Code: Select all
ReefAngel.CustomVar[0]=ReefAngel.IO.GetChannel(0);
ReefAngel.CustomVar[7]=1;

Then, on the Portal, you can set a trigger to send you alerts when C0 = 0.
Roberto.

Posts: 471
Joined: Sat Jan 14, 2012 2:08 pm
Location: Montgomery Village, MD
PostPosted: Thu Jun 28, 2012 6:56 pm
Thx Sir, I'll test it over the weekend.
Roscoe's Reefs - Starting Over Again:

Building new 29g Nano after landlord went berserk over my 4 75 gallon tanks, Multiple RA's, Water mixing stations, etc. Your help welcomed in remembering all I've forgotten.

Posts: 471
Joined: Sat Jan 14, 2012 2:08 pm
Location: Montgomery Village, MD
PostPosted: Tue Jul 03, 2012 4:45 pm
rimai wrote:Oh, in this case it is simple.
You can use one of the custom variables.
Code: Select all
ReefAngel.CustomVar[0]=ReefAngel.IO.GetChannel(0);
ReefAngel.CustomVar[7]=1;

Then, on the Portal, you can set a trigger to send you alerts when C0 = 0.


This is working fine...tell me again what custom var 7 is doing?
Roscoe's Reefs - Starting Over Again:

Building new 29g Nano after landlord went berserk over my 4 75 gallon tanks, Multiple RA's, Water mixing stations, etc. Your help welcomed in remembering all I've forgotten.

Posts: 12493
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Tue Jul 03, 2012 4:50 pm
Same thing as your Box1_Port8 is doing.
Making sure it keeps something that is non zero to keep that feature alive :)
Roberto.
Previous

Return to Portal

Who is online

Users browsing this forum: No registered users and 3 guests