Multi-Channel Water Level issue

Expansion modules and attachments

Posts: 66
Joined: Fri May 05, 2017 11:27 am
PostPosted: Mon Jun 12, 2017 10:00 pm
I setup my Multi-channel Water Level Expansion module on my new tank. Port 1 is for my ATO and so far has worked as well as I could have imagined. I've been watching it like a hawk, eyeballing the sump level and the reading. Heck, it works so well, it reminds me that I've turned my skimmer off because it reads higher than I would expect with normal evaporation... reason being I forgot I turned my skimmer off.

Port 2 is for my RO reservoir, and somethin' ain't right. I understand the issues of everything being airtight, but this is different. The Port 2 readings appear to be based on an algorithm tied to port 1 activity. As my sump level decreases, my Port 2 level decreases and as my sump level increases, my Port 2 level increases. The calibration acted very strange when setting 100%. My calibration numbers dropped around 1,000 while I was waiting for them to settle, which they never really did completely. I was bummed assuming I had an air leak. After I completed calibration, the initial reading was around 90 and drifted up to 115. I noticed that it declined over time, and finally bottomed out around 45 right before I started filling the sump (I haven't started using my ATO pump yet so I'm filling manually). After filling the sump, Port 2 went back up to 110. My ATO reservoir is near airtight, and I haven't taken a drop of water out of it so its water level hasn't changed more than a fraction of an inch. I will say that my Port 2 pipe is longer than the standard 9" (it is around 16.5"). However this doesn't explain Port 2's readings coinciding with Port 1's activity.

Also, Water Level Ports 3 and 4 show low values, even though they aren't active and haven't been calibrated. This isn't a big deal; it just seems they would show 0 or nothing.

Posts: 12509
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Wed Jun 14, 2017 2:59 pm
What happens if you use the other channels?

Posts: 66
Joined: Fri May 05, 2017 11:27 am
PostPosted: Wed Jun 14, 2017 10:00 pm
rimai wrote:What happens if you use the other channels?

I haven't tried moving to another channel/port on the Expansion module. It takes two people to calibrate because the controller doesn't reach that side of the stand. The Uapp looks like it will calibrate, but I tried that function, and it didn't do anything. I'm also handicapped and can't reach the Expansion module but do have someone helping me with the tank. The short of it is, I can try another channel/port on the module but will have to wait until I can get someone to help me. I guess I would also have to change my program to call out the new channel number.

I eventually want to use all four channels/ports so I was hoping I could focus on the channel where I'm having issues or my program, or whatever might be causing this. However, I'll troubleshoot in whatever manner you think is best.

Posts: 66
Joined: Fri May 05, 2017 11:27 am
PostPosted: Thu Jun 15, 2017 10:12 am
Update: I might have found the culprit. My ATO reservoir is a clear, plastic 11.75 gallon dog food container (I probably have 9-10 gallons of RO in the container. The container flexes with the weight of the water. Furthermore, my sensor is mounted on a long wall of the container, which is bowed-out a little. Last night, I pressed on the container, and that caused my reading to change. I opened the lid, and the reading dropped to zero for a second then started re-stabilizing (the lid obviously offers some support). My guess is that the container has been flexing, which is what has caused the odd readings. Also, the guy holding the sensor during calibration was likely also holding the container, and I'm pretty sure didn't have the lid down. Therefore, the container was likely flexing, which made my calibration go haywire. When the lid closed, the sides likely contracted, thereby creating pressure, causing my early readings of over 100. Actually, the readings have somewhat stabilized, hanging between the low 80's and upper 70's for the last day or so. Even after I messed with the tank last night and caused readings to go all over the place, this morning they were back to low 80's and upper 70's. If I'm right on this, sump weight (heavier after an ATO top-off, slightly flexing the wood in the base of the stand), temperature, even barometric pressure could effect my readings.

Question: will the calibration hold the 0% calibration value if I cancel through it and then allow me to calibrate the 100%? If so, this would be a simple way to test my theory and give me a fairly easy workaround to combat this. It doesn't have to be perfectly accurate as my main goal is to use to activate a solenoid to refill the container (I have a float valve for failsafe, and will timeout the solenoid once it has plenty of time to fill). I can also relocate the sensor to one of the short walls that don't flex as much if that might be compounding the issue.

Return to Addons

Who is online

Users browsing this forum: No registered users and 1 guest