Page 11 of 12

Re: Eheim autofeeder

PostPosted: Mon Mar 17, 2014 8:10 am
by lnevo
The code looks fine. It should be triggering FeedingMode at 6pm...

Everything else is based on being in FeedingMode. The fact that the relay triggered which can only happen when in FeedingMode means that worked. So either something cancelled the mode, or the time for Feeding is somehow set low. Did you by chance update that during troubleshooting. Can you verify the value in memory for your feeing time?

Re: Eheim autofeeder

PostPosted: Mon Mar 17, 2014 8:44 am
by Sacohen
Not sure if you are following me when I say it triggered.
Port 3 on my Power Control Module is triggering the relay I have to trigger the feeder (not connected yet).
Nothing else is getting triggered.

I did not adjust the feeding time, because it works fine when hit feeding on the head unit or on in the app on my phone.

I just checked the Feeding Mode Timer value from the Android app and it is set to 900 second like it should be.

Re: Eheim autofeeder

PostPosted: Mon Mar 17, 2014 9:30 am
by lnevo
Yes I followed you...

The only way that the Port3 on the power control module can be turned on based on the code you showed is when the RA is in Feeding Mode.

The only way code that affects the start of FeedingMode is the check at 6pm. The rest of the code is independent and your RA should be in FeedingMode and the rest should trigger properly. Based on what your describing it sounds like your only in Feeding Mode enough to trigger the autofeeder.

Not sure what is going on... I'll try another look but it seems odd to me that it's not staying in Feeding Mode...

Re: Eheim autofeeder

PostPosted: Mon Mar 17, 2014 10:04 am
by Sacohen
I'll double check it tonight.

If I follow you, what you are saying is that it will not go into feeding mode if I manually trigger Port3 on the power control module thru the Portal of off of my phone it will only go into feeding mode if Port3 on the power control module is triggered by the code.

Is that correct, because my basis for saying that it wasn't working was I turned Port3 on the power control module on from my phone and didn't see anything else related to feeding mode happen.

Re: Eheim autofeeder

PostPosted: Mon Mar 17, 2014 10:12 am
by lnevo
Ok, yeah you have the method of how this works totally wrong :)

At 6pm, your controller goes into feeding mode nothing else happens.

60 seconds into feeding mode the autofeeder turns on. At 61 seconds the feeder turns off. This can be any time feeding mode is called.

It's all based on when your controller goes into feeding mode not when a port goes on/off.

Re: Eheim autofeeder

PostPosted: Mon Mar 17, 2014 10:16 am
by Sacohen
Ok. I though that triggering the relay was what put it in feeding mode, besides trigger the feeder.

I'll double check that it is working as it should (rather than ad I thought) when I get home.

Sorry for taking up your time on a misunderstanding.

Sent from my HTC One VX using Tapatalk

Re: Eheim autofeeder

PostPosted: Mon Mar 17, 2014 11:02 am
by lnevo
No worries.

Re: Eheim autofeeder

PostPosted: Mon Mar 17, 2014 4:04 pm
by Sacohen
It works correctly. Thanks

Sent from my HTC One VX using Tapatalk

Re: Eheim autofeeder

PostPosted: Fri Mar 21, 2014 10:33 pm
by RootsRockReefer
very cool idea with the eheim auto feeder. will have read up on this!

Re: Eheim autofeeder

PostPosted: Sat Mar 22, 2014 4:30 am
by Sacohen
It is a cool idea. I just suck at soldering and haven't been able to attache the relay yo the feed button properly yet.
I toasted one feeder already.

Gonna pick up a new one today and sync it to the RA so I at least have a feeder for while I'm on vacation next week.