Web server basic authentication

Related to the development libraries, released by Curt Binder
User avatar
Posts: 5343
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Wed Dec 31, 2014 7:06 pm
Block Party...damn floridian..its 27 degrees in NY!! Happy New Year's everyone!!!
User avatar
Posts: 1833
Joined: Sun Apr 21, 2013 6:25 am
Location: Davie, FL
PostPosted: Wed Dec 31, 2014 7:09 pm
Yeah, my neighbors are Greek and cooking a goat on a spit.
User avatar
Posts: 5343
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Thu Jan 01, 2015 7:56 am
Nice!!!
User avatar
Posts: 1833
Joined: Sun Apr 21, 2013 6:25 am
Location: Davie, FL
PostPosted: Thu Jan 01, 2015 3:25 pm
Yeah, my wife and son said the goat was excellent. I was not feeling adventurous and didn't try it.

I loaded the new dev code and it is connection to the portal fine now and staying connected, before I believe it would connect after the initial loading of the code and then a bit later it would not and give me an unavailable address message.

What do I need to have Russ at reeftronics do to see if it works there?

Posts: 12201
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Thu Jan 01, 2015 3:29 pm
I'm pretty sure he is pulling data from /r99.
We need to tell them to change it to /sa.
Roberto.
User avatar
Posts: 1833
Joined: Sun Apr 21, 2013 6:25 am
Location: Davie, FL
PostPosted: Thu Jan 01, 2015 4:18 pm
Ok. I'll ask him to try, but before I do that I want to make sure that the code is working properly and we won't be changing things on him.

I just noticed that since putting the new dev code in that the Android app is giving me errors...

Error 13 Device Authentication Error.
check your username and password settings.

Posts: 213
Joined: Mon Apr 01, 2013 7:58 pm
PostPosted: Thu Jan 01, 2015 5:01 pm
Sacohen wrote:Ok. I'll ask him to try, but before I do that I want to make sure that the code is working properly and we won't be changing things on him.

I just noticed that since putting the new dev code in that the Android app is giving me errors...

Error 13 Device Authentication Error.
check your username and password settings.

I've been getting that error constantly for the last two months.. But yet I hit refresh and my app still uodates
User avatar
Posts: 1833
Joined: Sun Apr 21, 2013 6:25 am
Location: Davie, FL
PostPosted: Fri Jan 02, 2015 1:20 pm
Russ has enabled the /sa in the Reeftronics website. So if you enable the web authentication on your code it will still send information to Reeftronics.

Done! Well, that was surprisingly easy.

Apparently that /sa URI has been available all along. I was anticipating needing to modify my code to test if /r99 resulted in an authentication failure, then try /sa if needed. But I found that /sa works on all RAs on Reeftronics, so the necessary code change was really quite simple.
User avatar
Posts: 5343
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Fri Jan 02, 2015 5:07 pm
So does it query both or is there an option, or you have to resend your info to Russ? There's not much for Settings on the site..
User avatar
Posts: 1833
Joined: Sun Apr 21, 2013 6:25 am
Location: Davie, FL
PostPosted: Fri Jan 02, 2015 5:10 pm
Not sure. It sounds like it is querying the sa.
Maybe a better question for Russ to answer.
PreviousNext

Return to Development Libraries

Who is online

Users browsing this forum: No registered users and 1 guest

cron