Issues I've seen in the current Dev Library.

Related to the development libraries, released by Curt Binder
User avatar
Posts: 5355
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Tue Sep 30, 2014 6:16 pm
For the record I like 3% is a perfect amount :)

Roberto,

What else is left for us to release 1.1.11? Are there still hardware support items that you're dependent on for release? I haven't seen any bugs at this point other than to confirm the ph/date&time issue I had.

I think we should add a Release_Notes.txt file in the repo so we can all start working on our contrib items in one place. That would taunt me to actually add things there.

I know a few people are testing but we should probably also make an official call for additional beta testers.

Is there portal support still pending for things (threshold settings?)

I know we talked about doing some redesign on some things like threshold and offsets per channel in the PWM library...lets get 1.1.11 out so we can start on those for 1.1.12 :)

Anything I missed?
User avatar
Posts: 1833
Joined: Sun Apr 21, 2013 6:25 am
Location: Davie, FL
PostPosted: Tue Sep 30, 2014 6:25 pm
The only thing I know about for the Portal was the server authentication. Roberto may already have that set up in then next version of the Portal.
We also need to get with Reeftronics to set up for that feature or else you lose connectivity with them.

Posts: 12279
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Tue Sep 30, 2014 6:26 pm
I don't think there is anything pending except for making sure it is working.
Can you add the release notes file to the github?
Roberto.
User avatar
Posts: 5355
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Tue Sep 30, 2014 6:37 pm
Cool. I'll add the file and review the commits to see what can start going in. I'll get that other stuff verified too.

Steve, for reeftronics you should be able to add http authentication in the URL for your controller. Its not a portal issue they poll you directly. Just ask them to change the URL to:

http://user:password@your.ip.address:2000/r99
User avatar
Posts: 1833
Joined: Sun Apr 21, 2013 6:25 am
Location: Davie, FL
PostPosted: Tue Sep 30, 2014 6:45 pm
I know it's not a Portal issue.
I was saying that according to Roberto, the current Portal is not set for the server authentication.
I was also saying that Reeftronics would need something similar, but I can email Russ and see if he can do that with the URL.
User avatar
Posts: 5355
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Tue Sep 30, 2014 8:08 pm
That should work you can test that too to make sure the URL pulls up properly. He might have a problem storing it but i doubt it. He just uses php so shouldn't be a big deal.
User avatar
Posts: 5355
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Wed Oct 01, 2014 9:38 am
Any issue to use the README.md file for the release notes? Not sure if it's there for something like the mainpage.h :)

Posts: 12279
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Wed Oct 01, 2014 12:44 pm
Whatever you have on readme, gets displayed on the main page of github.com

Sent from my Galaxy S5 with Tapatalk
Roberto.
User avatar
Posts: 5355
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Wed Oct 01, 2014 12:47 pm
Well, I've created an initial stab at the release notes. I've made a pull request for it. You can track the branch "release" in my repo if you want to work on it until it's merged.

Ahh.. so I'll revert and move it to a separate file. :)

Edit: Updated. Also incremented version in ReefAngel.h to 1.1.1
User avatar
Posts: 1426
Joined: Fri Mar 29, 2013 3:51 pm
Location: Oklahoma City
PostPosted: Thu Oct 02, 2014 2:32 pm
I had this in the Reef Angel Status thread, but it's more appropriate here.

cosmith71 wrote:Possible bug? Library or programming issue?

On the dimming expansion screen:

Channel 0 is at 0%. I override to value x. Value changes to **x%. Clear override. Value changes to x% (not zero) and light stays on at x%. The only way to get it back to zero is to override to 0 and then clear.

I'm using this:

Code: Select all
  ReefAngel.PWM.Channel0PWMSlope(30);



--Colin


To which Lee replied:

lnevo wrote:
Expected behavior

Right which only sets the channel during your StandardLights time otherwise it uses the channels previous value.


I'm wondering if it would be better if this returned the min % in the off hours instead of the previous value?

--Colin
PreviousNext

Return to Development Libraries

Who is online

Users browsing this forum: No registered users and 2 guests

cron