Reef Angel Web Wizard

Community contributed apps

Posts: 12272
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Thu Mar 08, 2018 10:56 pm
I think it is the same
Roberto.

Posts: 15
Joined: Fri Feb 02, 2018 9:00 pm
Location: CA
PostPosted: Fri Mar 09, 2018 5:44 pm
I kept getting Error 400 last night. I'll try again tonight.

Sent from my Pixel XL using Tapatalk

Posts: 16
Joined: Fri Dec 27, 2013 8:22 pm
PostPosted: Fri May 11, 2018 4:09 pm
I just got the Cloud Portal. I downloaded the latest RA code, ReefAngelInstaller_1.1.3.exe. (I had 1.1.1 installed before that).

Installed.

Per the docs, used the WebWizard. Got a sketch. Copied it to my development machine (I use vMicro, but for this I used the RA Arduino fork executable). A snippet of the problem code:

Code: Select all
   ////// Place your custom code below here


   ////// Place your custom code above here

   ReefAngel.CloudPortal();
   // This should always be the last line
   ReefAngel.ShowInterface();


I get an error:

Code: Select all
Error: 'class ReefAngelClass' has no member function named 'CloudPortal'


Indeed, I downloaded the Github code (https://github.com/reefangel/Libraries) and find that the word "CloudPortal" does not exist in any of the library files, and is not a member of ReefAngel.cpp. I even followed breadcrumbs to https://github.com/lnevo but it's the same as what's checked in under ReefAngel.

So what do I have to do to get this to compile?

Thanks,

== John ==

Posts: 12272
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Fri May 11, 2018 4:25 pm
Try using the dev branch of the github
Roberto.

Posts: 16
Joined: Fri Dec 27, 2013 8:22 pm
PostPosted: Sat May 12, 2018 11:06 am
rimai wrote:Try using the dev branch of the github


That seems better, BUT ...

Then the "Dev" branch needs to be copied over, or the docs need updating. This is crazy.

I copied over the dev branch to my user folder (%USER%\Arduino) and now I'm getting a ton of compiler errors. Can't quite tell if the Dev branch is Arduino 1.0.1 or something newer. This is harder than it should be.

Is this product dead? :(

Posts: 12272
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sat May 12, 2018 11:14 am
No. The dev branch is the latest. It is what it is used on the web wizard.
I decided not use the Arduino IDE for mainstream anymore. It is only used for development.
The webwizard is what you want to use if you don't want to worry about compile errors.
Link for webwizard: we wizard
Now, if you are talking about doing library development, then it is another story. You will need the IDE.
So, I would suggest just going to webwizard and doing all the compiling and uploading in there.
Roberto.

Posts: 16
Joined: Fri Dec 27, 2013 8:22 pm
PostPosted: Wed Jun 13, 2018 3:09 pm
I am doing development :(

Or, I was ... I copied over my code into the web wizard and at least sort of got it to work.
Previous

Return to Apps

Who is online

Users browsing this forum: No registered users and 1 guest