iOS Reef Angel Uapp deprecated?

Community contributed apps

Posts: 10
Joined: Wed Feb 24, 2016 1:44 pm
PostPosted: Sat Dec 29, 2018 12:49 pm
Hi,

I just got a new iPad and the iOS Reef Angel Uapp (2.0.5) I’ve been using for the last couple years has been removed from the App Store. I’ve been searching the forums for the last 45 minutes looking for another solution.

I found references to the new web based uapp which sounds great but it seems to require the “cloud” WiFi attachment and I have the older non-cloud WiFi attachment.

The web portal kind of works to display status but I cannot click anything on it. In fact I cannot even login on the portal page itself because I can’t click the username and password fields to enter the information into them. I have to make sure I am logged in before clicking the link that loads the Portal. I think this may be an issue with the portal not supporting the mobile Safari web browser (or vice versa depending on your perspective :-)) because the portal worked fine on my wife’s Mac using Chrome.

Anyway, I’ll spend some more time looking through the forums tonight but if anyone has suggestions on my best course of action to replace the functionality of the old iOS app I’d love to hear them.

- Bill

Posts: 12493
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sat Dec 29, 2018 3:07 pm
uapp
Roberto.

Posts: 10
Joined: Wed Feb 24, 2016 1:44 pm
PostPosted: Sun Dec 30, 2018 6:02 am
rimai wrote:https://forum.reefangel.com/uapp


Are you saying the web based Uapp does *not* require a Cloud WiFi adapter? Because when I tried it yesterday it didn’t work. That, and the following text on the product page, is why I assumed it did require one. There is no such language on the non-cloud adapter’s page (not that it’s absence would preclude it from working with port forwarding configured).

Once the cloud wifi attachment is connected to the cloud server and your controller is setup, you will be able to control and monitor anywhere using the web based Uapp without any need of setting up port forwarding or anythihng else.


When I tried the web based Uapp, I used the same Name, IP Address, and Port that are working with the iOS app on the old iPad. I tried it both with my forum username/password in the Cloud Server section and with that section left blank. I tried it both ways after making sure that I was already authenticated to the forum in case there was some kind of cookie dependency. Nothing. No data on the status page. Can’t download labels. All relays showing off. Cloud Server usually shows “Connecting...”. Last Connected is always “never”. Forum username is always “Unknown”.

- Bill

Posts: 10
Joined: Wed Feb 24, 2016 1:44 pm
PostPosted: Sun Dec 30, 2018 6:17 am
I poked around in the web based Uapp some more. With forum credentials in the Cloud Server section, I can get it to show “Connected” instead of an infinite Connecting... but there is still no data. With or without those credentials in place The “Get RA version” command will return 1.1.3 I hadn’t tried that yesterday. Maybe it’s something...

Posts: 12493
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sun Dec 30, 2018 12:52 pm
With the regular wifi attachment, you should not enter the cloud credentials. Just name, ip address and port.
Also, because it cannot talk over https, you will need to load the uapp without ssl.
http://forum.reefangel.com/uapp
Roberto.

Posts: 10
Joined: Wed Feb 24, 2016 1:44 pm
PostPosted: Mon Dec 31, 2018 5:34 am
Okay, it’s working now. I’m not sure exactly which bit of saved information was causing the problem but unless you changed something on the server side there was something in my browser. Maybe a cookie from entering cloud server credentials during the first attempt? I don’t remember which way I tried first.

Anyway, in detail for future reference, here is what worked.
    Clear the browser cache/history/cookies/etc
    Go to http://forum.reefangel.com/uapp
    Load the Settings page
    Press Add Controller
    Input only the IP and port
    Press Save
    Load the Status page
    Press the hamburger button and select Download Labels from Portal
    Press the Refresh button
    Success!

    And thanks Roberto!

Return to Apps

Who is online

Users browsing this forum: No registered users and 1 guest

cron