UApp Error - Nothing to update

Community contributed apps

Posts: 100
Joined: Mon Sep 17, 2012 12:41 pm
Location: Lincoln Park, Chicago, IL, USA 60614
PostPosted: Mon Jan 07, 2019 8:35 am
Whenever I try to update the "Turn Daylights on at:" or "Turn Daylights off at:" internal memory fields in the UApp, I get the error "Alert: Nothing to update."

The fields are showing blank on in the UApp, i.e., there is no time showing in those fields.
User avatar
Posts: 5409
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Mon Jan 07, 2019 10:49 am
Try to set them manually to something through the web interface

http://your.ip.address:2000/mb244,8 // Set StdLightsOnHour to 8am
http://your.ip.address:2000/mb245,30 // Set StdLightsOnMinute to 30 minutes
http://your.ip.address:2000/mb246,20 // Set StdLightsOnHour to 8pm
http://your.ip.address:2000/mb247,30 // Set StdLightsOnHour to 30 minutes

Then it should have some values. Might not be dealing well with NULL in the original field.

Posts: 100
Joined: Mon Sep 17, 2012 12:41 pm
Location: Lincoln Park, Chicago, IL, USA 60614
PostPosted: Mon Jan 07, 2019 11:43 am
That was a good thought, but unfortunately, I still seem to be seeing blank fields in the UApp. The controller did return "OK" for each of the above calls. I tried rebooting the controller, and it still seems to show blanks.
User avatar
Posts: 5409
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Mon Jan 07, 2019 7:23 pm
Are you sure your Uapp is working properly? You have no portal key setup? or it's configured if you have one?
User avatar
Posts: 5409
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Mon Jan 07, 2019 7:24 pm
Have you tried in the portal? portal.php ?

Posts: 100
Joined: Mon Sep 17, 2012 12:41 pm
Location: Lincoln Park, Chicago, IL, USA 60614
PostPosted: Mon Jan 07, 2019 10:05 pm
I do have a portal key, which I set in my ReefAngel.Portal("sbidny", "<portal key>") call.

I am using the cloud server, and I can successfully set other internal memory fields. My Uapp is working for nearly every other function.

As for the portal, I'm not having much luck. It seems to log me out every few minutes. When I do log in, I am often greeted with a "Connection Status: Error - 500." And when it does say "Connection Status: Ready," I can't seem to update any of the internal memory fields anyway. It just says "Saving Internal Memory..." and never changes.

Posts: 100
Joined: Mon Sep 17, 2012 12:41 pm
Location: Lincoln Park, Chicago, IL, USA 60614
PostPosted: Mon Jan 07, 2019 10:09 pm
I see the problem. The memory locations you had me set were incorrect :)

Should be 204, 205, 206, and 207, not 244, 245, 246, and 247. Now I see the values again. Will try to update...

Posts: 100
Joined: Mon Sep 17, 2012 12:41 pm
Location: Lincoln Park, Chicago, IL, USA 60614
PostPosted: Mon Jan 07, 2019 10:13 pm
Now when I try to update them all, I get a "Timeout. Please try again." And the values get set to some random numbers.

Tried to update just the "Daylights on," and now it turned null again.
User avatar
Posts: 5409
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Mon Jan 07, 2019 10:28 pm
Odd. let's see what Roberto has to say. Sorry about the wrong numbers.

Posts: 12445
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Mon Jan 07, 2019 10:54 pm
I can't replicate.
Using Chrome, enable developer tools by pressing F12.
Then select the tab console.
You should see the MQTT messages that get exchanged.
Now, go to the internal memory tab of uapp.
You should see a very long string.
Copy and paste here.
Roberto.
Next

Return to Apps

Who is online

Users browsing this forum: No registered users and 1 guest

cron