Different settings for 2 different DC Pumps.

Requests for new functions or software apps

Posts: 263
Joined: Wed Jan 01, 2014 7:26 am
PostPosted: Thu Sep 04, 2014 4:18 pm
As far as I can tell the DCPump stuff is working fine on my reef angel with 2 and soon to be 4 (as soon as they clear customs) DC Pumps. I didn't make any changes to my INO file to get them to work either.
User avatar
Posts: 1833
Joined: Sun Apr 21, 2013 6:25 am
Location: Davie, FL
PostPosted: Thu Sep 04, 2014 4:36 pm
You shouldn't need to change anything for the pumps.
The only reason I did was because I had the Else Mode in my code and as part of my random waves.

That code had to be removed to use the code in the library.

Posts: 263
Joined: Wed Jan 01, 2014 7:26 am
PostPosted: Thu Sep 04, 2014 4:43 pm
Right. There are thankfully very few things that need to be changed in current .ino files to run the new code, but moving Else mode out is one of them. Now you can just do a
Code: Select all
ReefAngel.DCPump.Mode = Else;
in your INO, though, so that should be pretty simple for most folks.
User avatar
Posts: 1833
Joined: Sun Apr 21, 2013 6:25 am
Location: Davie, FL
PostPosted: Thu Sep 04, 2014 4:59 pm
Yeah. It should.
User avatar
Posts: 31
Joined: Fri Apr 19, 2013 1:00 pm
PostPosted: Thu Sep 11, 2014 6:44 am
So I have a question for you all (hopefully on this topic)
I downloaded libraries and used the wizard for my WP40 on the LowATO channel about 2 weeks ago. All I did was add 'LowATO=DCPump' (or something like that) to the code. I set it in Sine mode at 70%. 3 days later, the pump died on me.
Since I can only understand about half of what you all discuss here, did I do something wrong or it shouldn't have anything to do?
User avatar
Posts: 5342
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Thu Sep 11, 2014 7:04 am
You're using the dev libraries? You may need to raise the threshold (the default is 30) You may want to try 35.

ReefAngel.DCPump.Threshold=35;
User avatar
Posts: 31
Joined: Fri Apr 19, 2013 1:00 pm
PostPosted: Thu Sep 11, 2014 11:43 am
What does the threshold do and what could have it done to the pump? Yes I downloaded the dev libararies...
User avatar
Posts: 5342
Joined: Fri Jul 20, 2012 9:42 am
PostPosted: Thu Sep 11, 2014 11:46 am
If your speed goes too low on the dc jaebo pumps they cut off...the threshold sets the low end speed
User avatar
Posts: 1833
Joined: Sun Apr 21, 2013 6:25 am
Location: Davie, FL
PostPosted: Thu Sep 11, 2014 11:57 am
I have a WP-25 and a WP-40.
The cut off on my WP-40 is 25% and my WP-25 is 30%.
I can't say that is the limit for all of them thought.
User avatar
Posts: 31
Joined: Fri Apr 19, 2013 1:00 pm
PostPosted: Thu Sep 11, 2014 12:11 pm
OK, so it wouldn't damage the pump even if set too low. Am I correct?
PreviousNext

Return to Requests

Who is online

Users browsing this forum: No registered users and 1 guest

cron