Wireless Locking up

Requests for new functions or software apps
PostPosted: Sun Sep 16, 2012 7:03 am
I am having issues with attaching to the Rovingnetwork FTP server to upgrade the Wifly firmware. Have they changed the address again?

In the August 20th posting http://www.rovingnetworks.com/FAQs/I_get_FTP_Error_530_Login_Authentication_failed_when_I_try_to_upgrade_my_WiFly_module the address no longer works.

Does anyone have a current IP address?


Posts: 12519
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sun Sep 16, 2012 8:15 am
Yes, that's the last one I used.
They keep on changing it though. I've used about 3 or 4 servers already.
They got bought out by Microchip and until things settle, we will see this stuff happening.
I went ahead and used a FTP client and it did connect to that server.
PostPosted: Sun Sep 16, 2012 3:25 pm

I tried connecting to that address with an FTP client and got "530 User anonymous cannot log in" returned

In trying to upgrade my wifly I seem to have bricked it, your wizard does not resolve the problem neither does dmortons. Or I am doing something wrong. Do you have a working image of the firmware file? Or suggestion?

The reason for getting myself in this mess is that I had two wifi dropouts while I was away and thought this thread might solve the problem.

Posts: 12519
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sun Sep 16, 2012 4:04 pm
if you use tera term or putty, can you connect to it and issue commands?
Can you use "factory Reset" command?
the username for their ftp is Roving and password is Pass123. Both case sensitive.
PostPosted: Sun Sep 16, 2012 4:37 pm
Yes I can through Putty.

Thanks for FTP user an pw, will give it a try later.
PostPosted: Mon Sep 17, 2012 5:57 am
After several attempts I managed to get the firmware updated.

The latest version is 2.36

To get it to work I had to change several settings in the wifi config. Here are the commands that I sent to the Wifi.

1. Change the FTP server address to point to rn.microchip.co (IP )

Code: Select all
set ftp address

2. Change the FTP user name to roving (case sensitive)

Code: Select all
set ftp username roving

3. Change password to Pass123 (case sensitive)

Code: Select all
set password Pass123

4 Save changes

Code: Select all

5. Update firmware

Code: Select all
ftp update

6. Reboot

Code: Select all

The above worked for me on 17th September 2012, but the server address seems to change without notification as mentioned in a previous post.

I found it worthwhile to download the manual which I have attached.
WiFly 2.32-v1.0r (1).pdf
(1.57 MiB) Downloaded 197 times

Posts: 289
Joined: Wed May 16, 2012 9:52 pm
PostPosted: Mon Sep 17, 2012 8:02 pm
Posed this question in one of the other wifi threads. Thought I would ask here too.

Anyone try the 2.3.6/2.4.2/2.4.5 firmware updates yet?


Login: rovin
Password: Pass123

I see Sebyte has upgraded to 2.3.6 anything any better?
20GH QT#1
29G QT#2


Posts: 83
Joined: Sun Jul 29, 2012 6:47 pm
Location: Long Island, NY
PostPosted: Thu Sep 20, 2012 11:47 am
I'll have to see about upgrading my unit as well. While I was away on vaca this week I had to haven wife reboot the device which turned into a chore for her. Lol prior to that it was working decent since the last update.


Return to Requests

Who is online

Users browsing this forum: No registered users and 1 guest