Anyone programming from a Mac?

New members questions

Posts: 22
Joined: Mon Oct 19, 2020 1:35 pm
PostPosted: Sun Oct 25, 2020 4:37 pm
binder wrote:Well, both of those options / codes you posted compile just fine for me. I get no errors when I "verify". Here's the code that I used (from what you posted).

So, that makes me think there is an issue with the libraries location on your computer. I'm running macos 10.15.7 and arduino 1.8.13 plus the latest dev libraries.
My libraries folder contains exactly the same folders as the dev release (plus some extra code that I created). So it has to be your configuration/setup. Make sure that your Arduino preferences shows the Sketchbook location as:
Code: Select all
/Users/yourname/Documents/Arduino

Mine is:  /Users/binder/ownCloud/Documents/Arduino


Ok, so I just quit Arduino and then emptied the libraries folder. Then I downloaded the entire dev library from GitHub. I moved all those libraries into the /Users/rsweeney/Documents/Arduino/libraries folder. I launched Arduino and verified that the Sketchbook location is set to /Users/rsweeney/Documents/Arduino. I pasted the code you said was successful, then ran the CBTool and it did its thing. Then I clicked the Verify button and got the same exact errors as before. What could I possibly be doing wrong?
User avatar
Posts: 2846
Joined: Fri Mar 18, 2011 6:20 pm
Location: Illinois
PostPosted: Sun Oct 25, 2020 5:27 pm
Ok. Gonna do a couple more checks.
1. Paste the output of running my tool. It should be something like this:
Code: Select all
CBTool v2.0.1
Generating Features file from sketch_oct25a.ino
The following features were automatically added:
Watchdog Timer
Version Menu

The following features were detected:
Relay Expansion Module
Reef Angel Star
Number of Relay Expansion Modules: 1
Simple Menu

Finished detecting Features.
Generating Custom Labels file from sketch_oct25a.ino
Found Label: LABEL_PORT15 - Port 15
Found Label: LABEL_PORT13 - Port 13
Found Label: LABEL_PORT18 - Port 18
Found Label: LABEL_PORT16 - Port 16
Found Label: LABEL_PORT11 - Port 11
Found Label: LABEL_PORT17 - Port 17
Found Label: LABEL_PORT14 - Port 14
Found Label: LABEL_PORT12 - Port 12

Finished detecting Labels.
Ready to compile & upload.


2. If that looks good, then check out the version of the libraries.
Open up the libraries/ReefAngel/ReefAngel.h file and look for the line #define ReefAngel_Version "...". It will be towards the top, after the comments. Maybe around line 25. It should say this:
Code: Select all
#define ReefAngel_Version "1.1.3"


I'm having you check these because it sounds like the functions are not being enabled. The libraries contain a lot of define statements that remove sections of code that are not necessary or relevant. If the proper defines are not enabled, then the functions won't exist, which is what it sounds like is happening to you.

3. Lastly, check if you have an "update" folder inside your Sketch folder. You already created a "tools" folder in there. I'm guessing that you will need to create the "update" folder. If you do, then you will need to add the features.txt file I have attached to this post. THEN you can re-run my CB Tool to process the sketch and everything should work. If it does, great and my apologies for not having that available for you. I need to fix up the instructions and fix up the plugin to display proper error messages and warnings (that's what I get for just copying the code and not paying attention to it).
Attachments
feature.txt
Features files
(6.71 KiB) Downloaded 11 times

Posts: 22
Joined: Mon Oct 19, 2020 1:35 pm
PostPosted: Sun Oct 25, 2020 6:40 pm
After creating the "update" folder and putting the feature.txt file in it, the output of your tool NOW includes:

CBTool v2.0.1
Generating Features file from Reef_Angel_Initial_Setup.ino
The following features were automatically added:
Watchdog Timer
Version Menu

The following features were detected:
Relay Expansion Module
Reef Angel Star

Number of Relay Expansion Modules: 1
Simple Menu

Finished detecting Features.
Generating Custom Labels file from Reef_Angel_Initial_Setup.ino
Found Label: LABEL_PORT15 - Port 15
Found Label: LABEL_PORT13 - Refugium Light
Found Label: LABEL_PORT18 - Port 18
Found Label: LABEL_PORT16 - Port 16
Found Label: LABEL_PORT11 - Heater
Found Label: LABEL_PORT17 - Port 17
Found Label: LABEL_PORT14 - ATO
Found Label: LABEL_PORT12 - Return Pump

Finished detecting Labels.
Ready to compile & upload.

Those two bold lines were not there before.

And now the code compiles and I was able to upload it to the RA!!!

Curt, seriously, thank you for your assistance. I was just about ready to send this thing back.

Posts: 12713
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sun Oct 25, 2020 7:22 pm
I am also a lot to blame. I need to come up with a solid solution for Catalina release.
The background story is that when Catalina was released, Apple locked all 32-bit applications and the avrdude that is responsible for the upload of the code was compiled on 32-bit.
Since then, Arduino has patched the plugin to download the new 64-bit version of avrdude, but the current plugin needs to be updated and the webwizard also needs to be updated.
I had my MacOS VM crash and I just had it rebuilt from scratch, which should allow me to fix this thing now.
@ReeferRyan, would you be interested in working with me on fixing this since you are the first one with Catalina that can actually test things for me?
Roberto.
User avatar
Posts: 2846
Joined: Fri Mar 18, 2011 6:20 pm
Location: Illinois
PostPosted: Sun Oct 25, 2020 7:40 pm
ReeferRyan wrote:After creating the "update" folder and putting the feature.txt file in it, the output of your tool NOW includes:

CBTool v2.0.1
Generating Features file from Reef_Angel_Initial_Setup.ino
The following features were automatically added:
Watchdog Timer
Version Menu

The following features were detected:
Relay Expansion Module
Reef Angel Star

Number of Relay Expansion Modules: 1
Simple Menu

Finished detecting Features.
Generating Custom Labels file from Reef_Angel_Initial_Setup.ino
Found Label: LABEL_PORT15 - Port 15
Found Label: LABEL_PORT13 - Refugium Light
Found Label: LABEL_PORT18 - Port 18
Found Label: LABEL_PORT16 - Port 16
Found Label: LABEL_PORT11 - Heater
Found Label: LABEL_PORT17 - Port 17
Found Label: LABEL_PORT14 - ATO
Found Label: LABEL_PORT12 - Return Pump

Finished detecting Labels.
Ready to compile & upload.

Those two bold lines were not there before.

And now the code compiles and I was able to upload it to the RA!!!

Curt, seriously, thank you for your assistance. I was just about ready to send this thing back.

Awesome! Sorry it took so long to get it figured out. I just "assumed" those missing folders/files existed because they were already there from a previous install.

Posts: 22
Joined: Mon Oct 19, 2020 1:35 pm
PostPosted: Mon Oct 26, 2020 7:53 am
rimai wrote:I am also a lot to blame. I need to come up with a solid solution for Catalina release.
The background story is that when Catalina was released, Apple locked all 32-bit applications and the avrdude that is responsible for the upload of the code was compiled on 32-bit.
Since then, Arduino has patched the plugin to download the new 64-bit version of avrdude, but the current plugin needs to be updated and the webwizard also needs to be updated.
I had my MacOS VM crash and I just had it rebuilt from scratch, which should allow me to fix this thing now.
@ReeferRyan, would you be interested in working with me on fixing this since you are the first one with Catalina that can actually test things for me?


Yeah, I can help you. Sorry I didn't see this until now. Let me know what you need from me.
Previous

Return to For New Members

Who is online

Users browsing this forum: No registered users and 2 guests

cron