wifi attachment help

Post Reply
Reefology
Posts: 209
Joined: Fri Dec 26, 2014 6:38 pm

wifi attachment help

Post by Reefology »

Hi,

I recently changed my router and tried to change my ssid and passphrase on the RA+ wifi attachment with no luck. It worked flawlessly for years until I changed my router and now not sure how to proceed.

I followed the wifi setup documentation for all 3 methods and the result is always the same, IP address is 0.0.0.0;2000 and lights are flashing blue and green on the attachment.

can someone please help?

thanks
Image
rimai
Posts: 12880
Joined: Fri Mar 18, 2011 6:47 pm

Re: wifi attachment help

Post by rimai »

Does the SSID or pwd have a space? If so, replace it with a $
Roberto.
Reefology
Posts: 209
Joined: Fri Dec 26, 2014 6:38 pm

Re: wifi attachment help

Post by Reefology »

Hi Roberto, no neither ssid or passphrase have a space.

I reset WiFi attachment to factory settings and tried all 3 setup methods and still no luck. What else can I try?

Thanks
Image
rimai
Posts: 12880
Joined: Fri Mar 18, 2011 6:47 pm

Re: wifi attachment help

Post by rimai »

Do you get any response from the module when you use the Tera term method?
Roberto.
Reefology
Posts: 209
Joined: Fri Dec 26, 2014 6:38 pm

Re: wifi attachment help

Post by Reefology »

no I don't get anything?
Image
rimai
Posts: 12880
Joined: Fri Mar 18, 2011 6:47 pm

Re: wifi attachment help

Post by rimai »

Can you post the log that you get?
Are you sure you are selecting the correct COM port?
Roberto.
Reefology
Posts: 209
Joined: Fri Dec 26, 2014 6:38 pm

Re: wifi attachment help

Post by Reefology »

im definitely selecting the correct COM port.

not getting any log at all...I don't get the screen shown in step 16 of the wifi manual, screen is blank? not sure what to do?
Image
Reefology
Posts: 209
Joined: Fri Dec 26, 2014 6:38 pm

Re: wifi attachment help

Post by Reefology »

still blinking blue and ip is 0.0.0.0;2000

here is the log I get with WiFi utility:

Opening Serial Port...
Verifying speed at 9600 baud
Connected to serial port /dev/tty.usbserial-A402NUWP
> $$$
> set u b 57600
> set s p 0
> save
> reboot
Verifying speed at 57600 baud
Removing connection to /dev/tty.usbserial-A402NUWP
Connected to serial port /dev/tty.usbserial-A402NUWP
> $$$
< CMD
Wifi is communicating at 57600 baud rate

> reboot
< reboot
Removing connection to /dev/tty.usbserial-A402NUWP
---------------------------------------------------------------------
Wifi Attachment Connected to /dev/tty.usbserial-A402NUWP
---------------------------------------------------------------------

* Please, enter a SSID
Opening Serial Port...
Connected to serial port /dev/tty.usbserial-A402NUWP
> $$$
< CMD
> ls
< ls
<
< FL# SIZ FLAGS
< 2 86328 3 wifly-GSX-400
< 4 74920 3 web_app-GSX-106
< 7 46632 3 wps_app-GSX-131
< 9 66240 3 eap_app-GSX-101
< 11 37282 0 web_config.html
< 21 512 0 link.html
< 22 7268 0 logo.png
< 24 1052 10 config
< 25 88548 3 wifly-GSX-441-r1057
< 26 88548 3 wifly-GSX-441-r1057
< 27 1052 10 user
<
< 122 Free, Boot=26, Backup=2
< <4.41>
> load user
< load user
< AOK
< <4.41>
> save
< save
< Storing in config
< <4.41>
> save
< save
< Storing in config
< <4.41>
> set o d ReefAngelWifi
< set o d ReefAngelWifi
< AOK
< <4.41>
> set w l 5
< set w l 5
< AOK
< <4.41>
> set w s Deri
< set w s Deri
< AOK
< <4.41>
> set w p erefre
< set w p erefre
< AOK
< <4.41>
> set w k 00000000000000000000000000
< set w k 00000000000000000000000000
< AOK
< <4.41>
> set ftp address 198.175.253.161
< set ftp address 198.175.253.161
< AOK
< <4.41>
> save
< save
< Storing in config
< <4.41>
> reboot
< reboot
> $$$
< CMD
> show n
< show n
< SSid=Deri
< Chan=1
< Assoc=FAIL
< Rate=12, 24Mb
< Auth=FAIL
< Mode=NONE
< DHCP=FAIL
< Boot=0
< Time=OK
< Links=0
< <4.41>
> get i
< get i
< IF=DOWN
< DHCP=ON
< IP=0.0.0.0:2000
< NM=255.255.255.0
< GW=0.0.0.0
< HOST=104.36.18.155:80
< PROTO=TCP,
< MTU=1524
< FLAGS=0x6
< TCPMODE=0x0
< BACKUP=0.0.0.0
< <4.41>
> reboot
< reboot
Removing connection to /dev/tty.usbserial-A402NUWP
---------------------------------------------------------------------
Your Reef Angel Wifi Attachment is now configured with the settings provided.
---------------------------------------------------------------------

If the blue LED is still blinking, it means that the Reef Angel Wifi Attachment could not connect to your wifi network.

Found router CGN3ACSMR
Image
rimai
Posts: 12880
Joined: Fri Mar 18, 2011 6:47 pm

Re: wifi attachment help

Post by rimai »

Can you make sure the router can do B or G, because it cannot do N.
Roberto.
Reefology
Posts: 209
Joined: Fri Dec 26, 2014 6:38 pm

Re: wifi attachment help

Post by Reefology »

Sorry Roberto, I have no idea what that means or how to change it (if possible).

I received a new router from my service provider. Should I call them to have it switched?
Image
rimai
Posts: 12880
Joined: Fri Mar 18, 2011 6:47 pm

Re: wifi attachment help

Post by rimai »

Roberto.
Reefology
Posts: 209
Joined: Fri Dec 26, 2014 6:38 pm

Re: wifi attachment help

Post by Reefology »

RESOLVED

Went into my router... -> Wireless -> Wireless Mode
wireless setting default was "802.11 g/n mixed"...switched to "802.11 g only"
Success

Many thanks Roberto!
Image
Post Reply