Reef Angel Star Buzzer Issues

Basic / Standard Reef Angel hardware

Posts: 21
Joined: Mon Nov 23, 2020 5:40 pm
PostPosted: Tue May 25, 2021 11:40 am
Hello everyone, I just upgraded to the star from the plus. I have everything working great other than the buzzer keeps going off it is very faint and beeps continuously. I have deleted all buzzer code and it still doesn't change anything. I am lost. I don't have any flags or anything that would cause my buzzer to be on. Below is my code that has buzzer function in it. I also disconnected all attachments and it will still beep, but its faint.

#include <Salinity.h>
#include <ReefAngel_Features.h>
#include <Globals.h>
#include <RA_TS.h>
#include <RA_TouchLCD.h>
#include <RA_TFT.h>
#include <RA_TS.h>
#include <Font.h>
#include <RA_Wifi.h>
#include <RA_Wiznet5100.h>
#include <SD.h>
#include <SPI.h>
#include <Ethernet.h>
#include <EthernetDHCP.h>
#include <PubSubClient.h>
#include <Wire.h>
#include <OneWire.h>
#include <Time.h>
#include <DS1307RTC.h>
#include <InternalEEPROM.h>
#include <RA_ATO.h>
#include <LED.h>
#include <RA_TempSensor.h>
#include <Relay.h>
#include <RA_PWM.h>
#include <Timer.h>
#include <Memory.h>
#include <InternalEEPROM.h>
#include <RA_Colors.h>
#include <RA_CustomColors.h>
#include <RA_CustomLabels.h>
#include <RF.h>
#include <IO.h>
#include <ORP.h>
#include <AI.h>
#include <PH.h>
#include <WaterLevel.h>
#include <Humidity.h>
#include <PAR.h>
#include <DCPump.h>
#include <ReefAngel.h>
#include <SoftwareSerial.h>

////// Place global variable code below here


////// Place global variable code above here


void setup()
{
// This must be the first line
ReefAngel.Init(); //Initialize controller
ReefAngel.Star();
ReefAngel.AddSalinityExpansion(); // Salinity Expansion Module
ReefAngel.AddWaterLevelExpansion(); // Water Level Expansion Module
ReefAngel.AddORPExpansion(); // ORP Expansion Module
ReefAngel.AddLeakDetectorExpansion();
// Ports toggled in Feeding Mode
ReefAngel.FeedingModePortsE[0] = 0;
// Ports toggled in Water Change Mode
ReefAngel.WaterChangePortsE[0] = Port2Bit;
// Ports turned off when Overheat temperature exceeded
ReefAngel.OverheatShutoffPortsE[0] = Port4Bit | Port6Bit;
// Ports turned off when Leak is detected
ReefAngel.LeakShutoffPortsE[0] = Port3Bit | Port7Bit | Port8Bit;
// Ports toggled when Lights On / Off menu entry selected
ReefAngel.LightsOnPortsE[0] = 0;
// Use T1 probe as temperature and overheat functions
ReefAngel.TempProbe = T3_PROBE;
ReefAngel.OverheatProbe = T3_PROBE;
// Set the Overheat temperature setting
InternalMemory.OverheatTemp_write( 810 );
// Feeeding and Water Change mode speed
ReefAngel.DCPump.FeedingSpeed=0;
ReefAngel.DCPump.WaterChangeSpeed=0;

// Ports that are always on
ReefAngel.Relay.On( Box1_Port1 );
ReefAngel.Relay.On( Box1_Port4 );
ReefAngel.Relay.On( Box1_Port5 );


////// Place additional initialization code below here


////// Place additional initialization code above here
}

void loop()
{
ReefAngel.Relay.DelayedOn( Box1_Port2,5 );
ReefAngel.StandardLights( Box1_Port3,1,0,1,20 );
ReefAngel.StandardLights( Box1_Port6,23,0,11,0 );
ReefAngel.WaterLevelATO( Box1_Port7 );
ReefAngel.DosingPumpRepeat1( Box1_Port8);
ReefAngel.PWM.SetDaylight( PWMSlope( 11,45,21,30,20,60,240,0 ) );
ReefAngel.PWM.SetActinic( PWMSlope( 11,45,23,45,60,80,450,0 ) );
ReefAngel.DCPump.UseMemory = true;
ReefAngel.DCPump.DaylightChannel = None;
ReefAngel.DCPump.ActinicChannel = None;

ReefAngel.DCPump.ExpansionChannel[0] = Sync;
ReefAngel.DCPump.ExpansionChannel[1] = Sync;
ReefAngel.DCPump.ExpansionChannel[2] = AntiSync;
ReefAngel.DCPump.ExpansionChannel[3] = None;
ReefAngel.DCPump.ExpansionChannel[4] = None;
ReefAngel.DCPump.ExpansionChannel[5] = None;

boolean buzzer=false;
if ( ReefAngel.isATOTimeOut() ) buzzer=true;
if ( ReefAngel.isOverheat() ) buzzer=true;
if ( ReefAngel.isBusLock() ) buzzer=true;
if (ReefAngel.Params.Temp[T3_PROBE] >= 830 || ReefAngel.Params.Temp[T3_PROBE]<= 760) buzzer=true;
if (ReefAngel.WaterLevel.GetLevel()>= 85 || ReefAngel.WaterLevel.GetLevel()<= 60) buzzer=true;

if ( buzzer ) ReefAngel.BuzzerOn(2); else ReefAngel.BuzzerOff();

if(ReefAngel.WaterLevel.GetLevel() <= 0) ReefAngel.Relay.Off( Box1_Port7 );
if ( ReefAngel.Params.Temp[ T3_PROBE ] > 830 ) ReefAngel.PWM.SetDaylight( 0 );
if ( ReefAngel.Params.Temp[ T3_PROBE ] > 830 ) ReefAngel.PWM.SetActinic( 0 );
if ( ReefAngel.isLightsOnMode() == 1 ) ReefAngel.PWM.SetDaylight( 10 );
if ( ReefAngel.isLightsOnMode() == 1 ) ReefAngel.PWM.SetActinic( 70 );

if ( ReefAngel.HighATO.IsActive() == 1 ) ReefAngel.Relay.Off( Port3 );


////// Place your custom code below here


////// Place your custom code above here

ReefAngel.Network.Cloud();
// This should always be the last line
ReefAngel.ShowTouchInterface();
}



// RA_STRING1=U2FsdGVkX19daFKdnfsePMWCnvh9420pWLuv9n7HAOI=
// RA_STRING2=null
// RA_STRING3=null
// RA_LABEL LABEL_PORT16=Ref Light
// RA_LABEL LABEL_ACTINIC2=Not Used
// RA_LABEL LABEL_PORT15=Not Specified
// RA_LABEL LABEL_PORT13=AWC
// RA_LABEL LABEL_PORT18=DOS
// RA_LABEL LABEL_PORT11=Return Pump
// RA_LABEL LABEL_DAYLIGHT2=Not Used
// RA_LABEL LABEL_PORT14=Heater Controller
// RA_LABEL LABEL_PORT17=ATO
// RA_LABEL LABEL_DAYLIGHT=Daylight
// RA_LABEL LABEL_PORT12=Skimmer
// RA_LABEL LABEL_ACTINIC=Actinic

Posts: 21
Joined: Mon Nov 23, 2020 5:40 pm
PostPosted: Wed May 26, 2021 3:57 pm
Well after a couple late nights I finally figured out the issue. I have been using the remote upload and I believed it to be working. The RA* would download firmware and reboot and to me look like it was updating. Well I tried just a very basic code with nothing added (attachment wise) remotely and it downloaded updated and rebooted, but everything was the same. So the remote upload looked to be just reinstalling the same code I initially installed. I then flashed the RA with my laptop and the issue was fixed so super weird why the remote upload isn't working correctly or what code it was downloading, but at least no more beeping all night :)

Return to Standard

Who is online

Users browsing this forum: No registered users and 3 guests

cron