RA Star download firmware failed

Basic / Standard Reef Angel hardware
User avatar
Posts: 2868
Joined: Fri Mar 18, 2011 6:20 pm
Location: Illinois
PostPosted: Fri Oct 25, 2019 11:12 am
I'm running my star (finally) and I'm having some issues with it. I've chosen to upload code manually using my computer and arduino (not webwizard). I can upload just fine. However, I've been having issues that the Star attempts to download firmware remotely and it fails. The odd thing is that I haven't tried to do the remote uploading and haven't used it forever. I used the webwizard initially to get the proper includes for the sketches but that's it.

the failed download doesn't app to affect anything but replaces the date and time on the display. it just appears to be a visual annoyance more than anything.

What should I look at or where should I look to figure out what's going on?
I'm also running a relatively new version of the libraries from the git repository. The git code that I'm running is with the hash: 4781cde (which appears to be the latest version as of the time of this post).

Posts: 22
Joined: Mon Oct 19, 2020 1:35 pm
PostPosted: Mon Oct 26, 2020 7:36 am
Hey Curt....so you posted this a year ago, and here I am having the same exact issue after installing the code manually (with your valuable assistance).

What was your fix for this?

I'm working in the portal trying to make label name changes and when I click Save, the controller comes up and says "Downloading firmware failed..."
User avatar
Posts: 2868
Joined: Fri Mar 18, 2011 6:20 pm
Location: Illinois
PostPosted: Mon Oct 26, 2020 9:41 am
ReeferRyan wrote:Hey Curt....so you posted this a year ago, and here I am having the same exact issue after installing the code manually (with your valuable assistance).

What was your fix for this?

I'm working in the portal trying to make label name changes and when I click Save, the controller comes up and says "Downloading firmware failed..."
honestly I never figured out how to get it stop. I think there's some partial file on the server or something that the controller is trying to get (or thinks it needs to get).
i actually edited the libraries to ignore the main download part but it still happens at times.
so I just ignore it on my screen.

Sent from my Pixel 2 using Tapatalk

Return to Standard

Who is online

Users browsing this forum: No registered users and 8 guests