RA+ wifi connection - port forwarding

Community contributed apps
Post Reply
howaboutme
Posts: 245
Joined: Tue Jan 28, 2014 11:10 am
Location: Northern VA

RA+ wifi connection - port forwarding

Post by howaboutme »

Hi all,

I have my RA+ sitting in storage for 5+ years and want to set up a new tank. I've been tinkering with it for the last day or so and knowledge has started to trickle back (albeit slowly) into my brain. This question is about the wifi module and port forwarding.

Has anything changed in terms of how information is handled from the RA to the portal? I reset and set up my wifi module and can connect to it but the information is not being sent so I remembered that I need to port forward 2000. I think I did it by when I go some place like canyouseem.org, I get a different IP address (not the one given to me by the wifi module). It looks to be the external IP address? I have Verizon FIOS by the way.

I've done the searches in the forum but none seem to answer my question specifically and I've tried all of the suggestions that are somewhat close.

Below is my wifi code:

Code: Select all

Opening Serial Port...
Verifying speed at 9600 baud
Connected to serial port COM3
> $$$
> set u b 57600
> set s p 0
> save
> reboot
Verifying speed at 57600 baud
Removing connection to COM3
Connected to serial port COM3
> $$$
< CMD
Wifi is communicating at 57600 baud rate

> reboot
< reboot
Removing connection to COM3
---------------------------------------------------------------------
Wifi Attachment Connected to COM3
---------------------------------------------------------------------

Opening Serial Port...
Connected to serial port COM3
> $$$
< CMD
> ls
< ls
< 
< FL# SIZ FLAGS
<  11  19   3 WiFly_GSX-2.23  
<  30   1  10 config  
< 
< 1 Free, Boot=11, Backup=11
< <2.23> 
> set c c 0
< nÙº c c 0
< AOK
< <2.23> 
> set c r 0
< set c r 0
< AOK
< <2.23> 
> set c o 0
< set c o 0
< AOK
< <2.23> 
> set c i 3
< ûet c i 3
< AOK
< <2.23> 
> set c s 1420
< set c s 1420
< AOK
< <2.23> 
> set d n www.reefangel.com
< set d n www.reefangel®com
< AOK
< <2.23> 
> set i h 198.171.134.6
< set i h 198.171.134.6
< AOK
< <2.23> 
> set i r 80
< set i r 80
< AOK
< <2.23> 
> set i f 0x6
< set i f 0x6
< AOK
< <2.23> 
> set w j 1
< set w j°1
< AOK
< <2.23> 
> set u m 2
< set u m°2
< AOK
< <2.23> 
> set i p 2
< set i ø 2
< AOK
< <2.23> 
> set o d ReefAngelWifi
< ÿÙº o d ReefAngelWifi
< AOK
< <2.23> 
> set w l 5
< set w l 5
< AOK
< <2.23> 
> set w s ********
< set w s ********
< AOK
< <2.23> 
> set w p ********
< set w p ********
< AOK
< <2.23> 
> set w k 00000000000000000000000000
< ÿÙ¾ w k 0000000000000000000¸000000
< AOK
< <2.23> 
> set ftp address 198.175.253.161
< set ftp address 198¿Ì³3™³ÍfY3³fÃÅAOK
< <2.23> 
> save
< save
< Storing in config
< <2.23> 
> reboot
< reboot
> $$$
< CMD
> show n
< shÛ7d·
< SSid=********
< Chan=11
< Assoc=OK
< Rate=12, 24Mb
< Auth=OK
< Mode=WPA2
< DHCP=OK,renew=64799
< Boot=3102
< Time=FAIL
< Links=1
< <2.23> 
> get i
< ÷et i
< IF=UP
< DHCP=ON
< IP=192.168.1.205:2000
< NM=255.255.255.0
< GW=192.168.1.1
< HOST=198.171.134.6:80
< PROTO=TCP,
< MTU=1524
< FLAGS=0x6
< BACKUP=0.0.0.0
< <2.23> 
> reboot
< reboot
Removing connection to COM3
---------------------------------------------------------------------
Your Reef Angel Wifi Attachment is now configured with the settings provided.
---------------------------------------------------------------------

If the blue LED is still blinking, it means that the Reef Angel Wifi Attachment could not connect to your wifi network.

Found router FiOS-G1100


My RA+ code is in my signature and has not changed yet. I've confirmed things work by plugging the controller in but leaving the box empty.

Edit...

I did some more investigating. I reconfigured and got rid of the errors thanks to some old threads on using the terra term method. I was able to get it to connect to http://my ip/wifi but then I occasionally get the "unable to connect" try again notice.

Question about port forwarding still stands. I remember using http://freedns.afraid.org/ and I still have the account (was dormant but now live) and still have the told tank-stats.com url that was recommended and my exterior ip is still the same but I'm not sure what to do next.

Edit2:

What my fios portal says:
Capture.JPG
Capture.JPG (13.86 KiB) Viewed 5521 times
Thanks!
Last edited by howaboutme on Mon Dec 28, 2020 4:31 am, edited 1 time in total.
Jack
rimai
Posts: 12881
Joined: Fri Mar 18, 2011 6:47 pm

Re: RA+ wifi connection - port forwarding

Post by rimai »

Update the settings of your wifi module: https://forum.reefangel.com/viewtopic.php?f=3&t=4601
Roberto.
howaboutme
Posts: 245
Joined: Tue Jan 28, 2014 11:10 am
Location: Northern VA

Re: RA+ wifi connection - port forwarding

Post by howaboutme »

rimai wrote:Update the settings of your wifi module: https://forum.reefangel.com/viewtopic.php?f=3&t=4601
I did do that and still nothing on port forwarding. Everything connected fine w/ Terra Term and I let it do its thing until the "Start WiFi Module Configuration" window showed up again. Then I exited and ran the wifi config utility again. It seems to connect fine although it does give me an "unable to connect" warning at times as said previous.

Any other thoughts? Thanks!
Jack
rimai
Posts: 12881
Joined: Fri Mar 18, 2011 6:47 pm

Re: RA+ wifi connection - port forwarding

Post by rimai »

Can you post the log of teraterm after you update the settings?
The one above is still pointing to the wrong server.
Roberto.
howaboutme
Posts: 245
Joined: Tue Jan 28, 2014 11:10 am
Location: Northern VA

Re: RA+ wifi connection - port forwarding

Post by howaboutme »

rimai wrote:Can you post the log of teraterm after you update the settings?
The one above is still pointing to the wrong server.
Ok, I did that but I also realized a few things. After I first did the terra term instructions, I also did the wifi config utility. I think that's why you see the wrong server.

I then did the terra term thing again and I don't think it worked. My log is just a bunch of the same symbols?

Code: Select all

CMD
factory RESET
Set Factory Defaults
<2.23> reboot
*Reboot*ààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààààààààààààààààààààààààààààààààààààààààààààààààààààààà                                        ààààààààà
It just stops at that when the window asking if I want to configure shows up. I exit out of that but not before I did it twice just to be sure.

Thoughts?
Jack
rimai
Posts: 12881
Joined: Fri Mar 18, 2011 6:47 pm

Re: RA+ wifi connection - port forwarding

Post by rimai »

That doesn't look correct.
Try again.
Roberto.
howaboutme
Posts: 245
Joined: Tue Jan 28, 2014 11:10 am
Location: Northern VA

Re: RA+ wifi connection - port forwarding

Post by howaboutme »

I think I figured it out. It was able to work with 9600 and NOT 57600.

Here's the code:

Code: Select all

CMD
factory RESET
Set Factory Defaults
<2.23> reboot
*Reboot*WiFly Ver 2.23, 04-26-2011 on 131C11
MAC Addr=00:06:66:14:d8:88
Auto-Assoc roving1 chan=11 mode=NONE FAILED
*READY*
CMD
set ftp address 198.175.253.161
AOK
<2.23> save
Storing in config
<2.23> set wlan ssid -----
AOK
<2.23> set wlan pass ------
AOK
<2.23> set option deviceid ReefAngelWifi
AOK
<2.23> set w j 1
AOK
<2.23> set c c 0
AOK
<2.23> set c r 0
AOK
<2.23> set c o 0
AOK
<2.23> set i d 1
AOK
<2.23> set c i 3
AOK
<2.23> set dns name www.reefangel.com
AOK
<2.23> set i h 104.36.18.155
AOK
<2.23> set i r 80
AOK
<2.23> set i f 0x06
AOK
<2.23> set s t 0x10
AOK
<2.23> set u m 2
AOK
<2.23> set i p 2
AOK
<2.23> set u b 57600
AOK
<2.23> set s p 0
AOK
<2.23> set c s 1420
AOK
<2.23> save
Storing in config
<2.23> save user
Storing in user
<2.23> reboot
*Reboot*
I reconnected the attachment to the head unit and I get a slow green blink with the occasional flashes of yellow indicating it is forwarding data. Going to the controller internal portal I still get unable to retrieve data and now a dns error.

Thoughts? Thanks!
Jack
rimai
Posts: 12881
Joined: Fri Mar 18, 2011 6:47 pm

Re: RA+ wifi connection - port forwarding

Post by rimai »

Good.
We can see data in the portal now.
You just need to figure out the port forwarding now.
Do you have any other wifi router besides the Fios?
Roberto.
howaboutme
Posts: 245
Joined: Tue Jan 28, 2014 11:10 am
Location: Northern VA

Re: RA+ wifi connection - port forwarding

Post by howaboutme »

Thanks Roberto! I see it in the portal now.

I also figured out the port forwarding. I re-used what I set up years ago which was using tank-stats.com and I inputted that into Curt's android app and everything is connecting so far. Things are slowly coming back to me. Note that since I'm still playing with it w/ no tank, I will not have the controller powered up for too long, just for configurations.

Quick question. I was playing around w/ the wizard and at the end, it asked for dynamic dns server. I put my tank-stats.com address in and noticed that the new code now has

Code: Select all

 ReefAngel.DDNS( "howaboutme.tank-stats.com" ); // Your DDNS is howaboutme-howaboutme.tank-stats.com.myreefangel.com
I know my current code in the controller does not have this line. What's the difference? Is it for some new options, the wifi cloud or what? Just wondering.

PS. I'll be ordering some replacement parts soon. Thanks
Last edited by howaboutme on Mon Dec 28, 2020 11:27 am, edited 1 time in total.
Jack
rimai
Posts: 12881
Joined: Fri Mar 18, 2011 6:47 pm

Re: RA+ wifi connection - port forwarding

Post by rimai »

Delete the line.
DDNS is not working anymore.
Roberto.
howaboutme
Posts: 245
Joined: Tue Jan 28, 2014 11:10 am
Location: Northern VA

Re: RA+ wifi connection - port forwarding

Post by howaboutme »

Got it. Thanks!

Another question. Will access to the information from the RA Portal be available outside of my network? Does it have to do with port forwarding at all or just the android/iphone apps?
Jack
rimai
Posts: 12881
Joined: Fri Mar 18, 2011 6:47 pm

Re: RA+ wifi connection - port forwarding

Post by rimai »

Portal data is available anywhere. The controller sends data to portal every 5 min
Roberto.
howaboutme
Posts: 245
Joined: Tue Jan 28, 2014 11:10 am
Location: Northern VA

Re: RA+ wifi connection - port forwarding

Post by howaboutme »

Thank you Roberto! I'm good for now at least until I get my tank up.
Jack
howaboutme
Posts: 245
Joined: Tue Jan 28, 2014 11:10 am
Location: Northern VA

Re: RA+ wifi connection - port forwarding

Post by howaboutme »

Roberto or anyone.

Need some help. I just setup my google wifi and am switching everything over from the Verizon router. I am using a new SSID and pswd. I used terra term (per post previous) and uploaded the new info to the wifi attachment. The attachment has the green light (no blue). from there, I'm not sure what is going on.

I am able to see a generic screen at http://http://xxx.xxx.xx.xx:2000/wifi (no info, just zeros). I'm not sure if that is right or wrong.

From there I'm trying to port forward on the google home app and it's a bit confusing. It's asking me for internal and external. I put 2000 on both and click TCP but it's saying that its failed to add rule and to check internal and external.

first, do you see my RA in the portal? It currently says unreachable address but the last update is current and #'s seem correct. If you can see that, then I can isolate it to port forwarding.

Anyone have experience doing this w/ google/nest wifi?

thanks in advance!
Jack
howaboutme
Posts: 245
Joined: Tue Jan 28, 2014 11:10 am
Location: Northern VA

Re: RA+ wifi connection - port forwarding

Post by howaboutme »

NM. Forgot to forward both routers. :D
Jack
Post Reply