Wifi keeps disconnecting

Basic / Standard Reef Angel hardware

Posts: 58
Joined: Mon Oct 01, 2018 5:55 pm
PostPosted: Thu Oct 24, 2019 4:39 pm
Are there any tips or tricks I can do to get the wifi attachment to be more stable?

It’s hit or miss when it comes to its connection.
I can connect and refresh 5x with no issues sometimes, then when I try to connect 3 minutes later it’s offline and can’t connect. It’s off and on like this all the time.

Connects fine sometimes. Other times it won’t be able to connect for hours.
I don’t touch anything, the connection gets established.
It’s just really strange behavior with the wifi attachment and completely unstable.

It does have the latest update. It’s set with a static IP and all my port forwarding rules are working.
It’s the same behavior if I am connecting locally or remotely.

Posts: 26
Joined: Fri Feb 02, 2018 9:00 pm
Location: CA
PostPosted: Fri Oct 25, 2019 3:24 pm
Mine seems to work better with the case off. The cable plug makes better contact that way.

Sent from my Pixel XL using Tapatalk

Posts: 12628
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sat Oct 26, 2019 1:38 pm
Or you can add an external antenna too. Search the forums. Someone did it with good results.
A better solution is the cloud wifi attachment that maintains an always on connection to the cloud server and you don't need to keep making connections to the attachment itself.
Roberto.

Posts: 58
Joined: Mon Oct 01, 2018 5:55 pm
PostPosted: Sat Nov 23, 2019 5:49 pm
For future reference here is the link I found about adding an antenna.
Sounds like a good idea. I’m doing it :)

http://forum.reefangel.com/viewtopic.ph ... al+antenna

Posts: 58
Joined: Mon Oct 01, 2018 5:55 pm
PostPosted: Sat Nov 23, 2019 6:36 pm
I remember reading something at some point about changing the timeout setting on the wifi attachment. Its currently at the default of 200.
Is this something i should try?
Are there any other tweaks in the wifi settings that may help it stay connected at all times?

I am trying the xternal antenna, but in all honesty it does not seem like a connection strength issue. When i unplug the wifi attachment (when connection fails) and plug it right back in, it connects within seconds. I need to do this regularly.

Here is my current code on the wifi attachment:
Code: Select all
wifly-GSX Ver: 4.41 Build: r1057, Jan 17 2014 10:26:29 on RN-131
SSID=WiFly-GSX-7f
Pass=
Linkmon=3600
Beacon=102
Reboot=0
IF=UP
DHCP=ON
IP=192.168.2.201:8080
NM=255.255.255.0
GW=192.168.2.1
HOST=re.mo.ve.d80
PROTO=TCP,
MTU=1524
FLAGS=0x6
TCPMODE=0x0
BACKUP=0.0.0.0
OPEN=
CLOSE=
REMOTE=
FlushSize=1420
MatchChar=0
FlushTimer=5
IdleTimer=3
CmdChar=$
DNS=8.8.8.8
Name=www.reefangel.com
Backup=rn.microchip.com
Lease=86400
FTP=re.mo.ve.d:21
File=wifly-GSX.img
User=roving
Pass=re.mo.ve.d
Dir=public
Timeout=200
FTP_mode=0x0
SSID=re.mo.ve.d
Chan=0
ExtAnt=1
Join=1
Auth=MIXED
Mask=0x1fff
Rate=12, 24 Mb
Linkmon=5
Passphrase=re.mo.ve.d
EAP_Id=userid
EAP_User=peap-user
SleepTmr=0
WakeTmr=0
Trigger=0x10
Autoconn=0
IoFunc=0x0
IoMask=0x20f0
IoValu=0x0
DebugReg=0x0
PrintLvl=0x0
LaunchStr=web_app
TimeEna=0
TIMEADR=re.mo.ve.d:123
Zone=7
Baudrate=57600
Flow=0x0
Mode=0x2
Cmd_GPIO=0
JoinTmr=1000
Replace=0x24
DeviceId=ReefAngelWifi
Password=
Format=0x0
Signal=0
Average=5
BCAST=255.255.255.255:55555
Interval=0x7
Backup=0.0.0.0:0
Sensor=0x0
SensePwr=0x0

Posts: 12628
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Sun Nov 24, 2019 11:23 am
When it disconnects, does it blink blue?
Roberto.

Posts: 26
Joined: Fri Feb 02, 2018 9:00 pm
Location: CA
PostPosted: Sun Nov 24, 2019 12:43 pm
alexr54 wrote:For future reference here is the link I found about adding an antenna.
Sounds like a good idea. I’m doing it :)

http://forum.reefangel.com/viewtopic.ph ... al+antenna
That antenna is no longer in stock, can we use other ones listed that are I'm guessing are stronger?

@rimai when mine loses connection yes it's blinking blue.

Sent from my Pixel 4 XL using Tapatalk

Posts: 58
Joined: Mon Oct 01, 2018 5:55 pm
PostPosted: Sun Nov 24, 2019 3:43 pm
I got this antenna and it is working fine


WiFi Antenna 8dBi Omni RP SMA Male RPSMA Antenna 2.4Ghz 5.8Ghz Dual Band + 20cm U.FL to RP-SMA Female Extension Cable for Mini PCIe Card Notebook PS4 Drone 1 Pcs https://www.amazon.com/dp/B07QKD56TT/re ... 2DbPK5KF89


It did timeout once since I installed the antenna but a few minutes later it worked fine.
Next time it times out I’ll look to see what color is blinking.

Posts: 26
Joined: Fri Feb 02, 2018 9:00 pm
Location: CA
PostPosted: Sun Nov 24, 2019 5:03 pm
alexr54 wrote:I got this antenna and it is working fine


WiFi Antenna 8dBi Omni RP SMA Male RPSMA Antenna 2.4Ghz 5.8Ghz Dual Band + 20cm U.FL to RP-SMA Female Extension Cable for Mini PCIe Card Notebook PS4 Drone 1 Pcs https://www.amazon.com/dp/B07QKD56TT/re ... 2DbPK5KF89


It did timeout once since I installed the antenna but a few minutes later it worked fine.
Next time it times out I’ll look to see what color is blinking.
Thanks!

Sent from my Pixel 4 XL using Tapatalk

Posts: 58
Joined: Mon Oct 01, 2018 5:55 pm
PostPosted: Mon Nov 25, 2019 11:26 am
rimai wrote:When it disconnects, does it blink blue?


Yes it is blinking blue.
Next

Return to Standard

Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot] and 8 guests

cron