Trouble with getting started

Would you like to help?
Share your walkthrough tutorial with others

Posts: 2
Joined: Thu Apr 05, 2012 3:49 pm
PostPosted: Thu Apr 05, 2012 4:08 pm
I have looked around, and have not yet found the answer to what I have going on.

I am new to the reef angel and new to programming at any level. The reef angel is working just fine on the preloaded code, and it appears to communicate with my computer.

However, I cannot currently progress beyond that. I have tried to use RAGen (I have already run RA update utility) to generate the internal memory values .ino file, but when I go to the Arduino program to verify it before uploading, I get an error message saying there was an "error compiling" The pane that shows what is wrong says (and I wish I could cut and paste it) among other related things: "RA_NokiaLCD.cpp:1318:error 'class TwoWire' has no member named 'read'"

It does not seem to matter whether I am doing the verify while attached to the powered RA. If I am supposed to be hooked to the RA, should the RA be plugged in to power?

Posts: 12758
Joined: Fri Mar 18, 2011 6:47 pm
PostPosted: Thu Apr 05, 2012 4:29 pm
I think you downloaded a previous version of installer/libraries at one point, which caused some mismatch.
My suggestion is:
Uninstall the Reef Angel Installer you currently have
Rename the libraries folder to librariesold - It's located at "\Documents\Arduino\libraries"
Download the new installer from
Install it again

Posts: 2
Joined: Thu Apr 05, 2012 3:49 pm
PostPosted: Thu Apr 05, 2012 5:25 pm
Yep. That solved it.

I had uninstalled it and reinstalled a fresh copy last night, but did not think to rename the libraries folder in between.

The Internal memory code verifies fine now. I'll see if I can upload it when I get home tonight.


Return to Tutorials

Who is online

Users browsing this forum: No registered users and 0 guests